Bug 10526 - Error message during startup: "unary operator expected"
Error message during startup: "unary operator expected"
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: tksysv (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-02 15:59 EDT by wb8foz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wb8foz 2000-04-02 15:59:31 EDT
I used the control panel run level editor to modify what starts when. Now, when
booting or shutting down, I get a error message for several modules.
The message is "unary operator expected" and is presented when
network nfs, inet, lpd and sendmail [start|stop]...
Comment 1 Nalin Dahyabhai 2000-04-03 12:57:59 EDT
The scripts themselves are scattered across the initscripts, lpd, and sendmail
packages.  Which versions of these do you have installed?
Comment 2 Nalin Dahyabhai 2000-04-03 14:03:59 EDT
Per private email:
>All the standard 6.1 versions; i.e. I upgraded with a 6.1 CD & have
>not done anything since...
>
>It LOOKED to naive me as if it were the rc.d scripts generating
>the errors, not the packages....

The scripts are included in the respective packages.  I'm not able to reproduce
this here by twiddling the start and stop settings for sendmail.  Can you verify
that running the affected scripts with either "start" or "stop" as the only
argument on the command-line (i.e., "/etc/rc.d/init.d/sendmail start" or
"/etc/rc.d/init.d/sendmail stop") breaks?  If so, does running them via
"sh -x /etc/rc.d/init.d/sendmail stop" show where the script is dying?
Comment 3 Bill Nottingham 2006-08-07 13:28:39 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 10:34:14 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.