Bug 10527 - failure of aic7xxx.o under insmod
failure of aic7xxx.o under insmod
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-02 17:08 EDT by clshier
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-03 23:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description clshier 2000-04-02 17:08:44 EDT
This is a plea for help!


I am attempting to load a Red Hat 6.1 Deluxe box version on:
      Gateway 2000  E-5200-700
      Single Pentium III on a dual capable motherboard
      ACPI ASIC on motherboard
      256MB RAM
      AMIBIOS Build 25 Version OAANG025
      3DLabs Oxygen VX1 at AGP port
      Toshiba XM-6401TA Fast/Ultra SE CDROM at Target 5 LUN 0 of
           SCIS BUS 0
      Two IBM DMVS09N LVD 9.1GB Hard Disks at Targets 0 and 1 LUN 0 of
           SCSI BUS 0
           (Because they are forced to by Microsoft, Gateway loaded Windows
             2000 Professional on drive at Target 0.  I will use Target 1
             for Linux 6.1)
      Adaptec AHA-2940U2 PCI to Ultra SCSI Adapter at PCI bus 0
           Device 17 Function 0
           SCSI BIOS Version 2.11.0 (c) 1998
           Uses Address Range  FFAFF000 to FFAFFFFF
           Uses I/O Range          EC00 to     ECFF

My installs always end at the following infinite loop:
      <4> SCSI host 0 abort (pid 0) timed out - resetting
      <4> SCSI bus is being reset for host 0 channel 0.
      <4> SCSI host 0 channel 0 reset (pid 0) timed out - trying harder

These 3 messages repeat ad nauseam (my patience runs out after 10 min)

The repeating sequence is immediately preceeded by
      <4> scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-FAST SCSI)
           5.1.20/3.2.4
      <6> (scsi0) <Adaptec AHA-294X Ultra2 SCSI host adapter> found at
           PCI 17/0
      <6> (scsi0) Wide Channel, SCSI ID = 7, 32/255 SCBs
      <6> (scsi0) Downloading sequencer code... 374 instructions
           downloaded
      <4> scsi : 1 host.
      <4> scsi : aborting command due to timeout: pid0, scsi0,
           channel0, id0, lun0  Test Unit Ready 00 00 00 00 00

This sequence of SCSI related messages occurs when the F3 screen
reads
      * going to insmod fat.o (path is NULL)
      * going to insmod vfat.o (path is NULL)
      * 65 keymaps are available
      * loaded 9 keymaptables
      * going to insmod aic7xxx.o (path is NULL)

Once loop is entered the page up, page down and console change keys
no longer function.  (Must read messages rapidly before they scroll)
The only way out of loop is Ctrl-Alt-Del.

I have several pages of messages prior to the aic7xxx.o sequence if
you need them to aid debugging.  Also this failure happens when I use

      the CDROM disk 1 from the box
   or
      the floppy diskette from the box
   or
      the boot-RHEA-1999:044.img I downloaded from Red Hat (it never gets
         to the updates image I also downloaded)
   and
      every conceivable combination of expert, text, and readily
      available driver option "strings"

In all cases the loading is labelled with this line
      syslinux 1.45 1999-06-14 copyright (c) 1994-1999 H. Peter Anvin


I have called the Red Hat Tech Support line several times and they all
insisted I download the boot and updates images before they would try
to debug this problem.  I have now established that the new images make
no difference.

Red Hat has opened Case 291639 for this support request.

If you have any idea what this problem is and how to fix it, please contact
me at clshier@swcp.com or shierwood@aol.com.
Comment 1 Doug Ledford 2000-05-22 14:37:59 EDT
You're using an old version of Red Hat with an old version of the aic7xxx
driver.  Please try updating your driver using the disk image and instructions
found on my web site:

http://people.redhat.com/dledford
Comment 2 clshier 2000-06-03 23:15:16 EDT
Thanks for the response!

Actually someone at Red Hat had sent me an email suggesting I visit your
site and get the latest updated drivers.

I did that and was successful in getting past this problem.

Now I just wish I had some way to use the fancy abilities of my 3DLabs
video card instead of just the Frame Buffer Device version of the X server.
Oh well ... can't complain too much considering the low cost of the Red Hat
package.

Thanks again.

Craig

Note You need to log in before you can comment on or make changes to this bug.