Bug 105337 - perl-5.6.1-36.1.99ent.i386.rpm dependency problems
perl-5.6.1-36.1.99ent.i386.rpm dependency problems
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: perl (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-24 22:29 EDT by Kent
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-22 19:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kent 2003-09-24 22:29:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I've run across the following dependency problem when installing the latest 
security fix for perl-5.6.1-36.1.99ent.  This has been replicated on four 
servers -

 
[spike rhn-packages09-23-03]# rpm -Fvh perl-5.6.1-36.1.99ent.i386.rpm 
error: failed dependencies:
		   perl-suidperl is needed by perl-5.6.1-36.1.99ent
 
So I tried installing perl-suidperl and got the following -
 
[spike]# rpm -ivh perl-suidperl-5.6.1-36.1.99ent.i386.rpm 
Preparing  ###############################
[100%]
file /usr/bin/sperl5.6.1 from install of perl-suidperl-5.6.136.1.99ent
conflicts with file from package perl-5.6.1-26.72.4
file /usr/bin/suidperl from install of perl-suidperl-5.6.1-36.1.99ent
conflicts with file from package perl-5.6.1-26.72.4

Version-Release number of selected component (if applicable):
perl-5.6.1-36.1.99ent 

How reproducible:
Always

Steps to Reproduce:
1.  See description
    

Actual Results:  See description

Expected Results:  The patched RPM should have installed.

Additional info:
Comment 1 Chip Turner 2003-09-24 23:32:42 EDT
try putting both the perl and the perl-suidperl packages on the same command
line, as well as the other packages in the errata
Comment 2 Kent 2003-09-25 09:07:33 EDT
Putting both progs on the same line worked -

[spike rhn-packages09-23-03]# rpm -Uvh perl-suidperl-5.6.1-36.1.99ent.i386.rpm
perl-5.6.1-36.1.99ent.i386.rpm 
Preparing...                ########################################### [100%]
   1:perl-suidperl          ########################################### [ 50%]
   2:perl                   ########################################### [100%]

This may have not warranted a bug report but that is where tech support referred me.
Thanks,
Kent

Note You need to log in before you can comment on or make changes to this bug.