Bug 105351 - strace -fF hangs on kernel-2.2.x
strace -fF hangs on kernel-2.2.x
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Roland McGrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-25 07:22 EDT by Dmitry V. Levin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 04:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system.c (83 bytes, text/plain)
2003-09-25 07:26 EDT, Dmitry V. Levin
no flags Details
strace-4.4.99.log (1.30 KB, text/plain)
2003-09-25 07:26 EDT, Dmitry V. Levin
no flags Details

  None (edit)
Description Dmitry V. Levin 2003-09-25 07:22:15 EDT
Description of problem: 
strace-4.4.99 hangs while tracing with -fF options on kernel-2.2.25 
strace-4.4 works whith the same test on the same kernel. 
strace-4.4.99 works whith the same test on various kernels >= 2.4.20 
 
Version-Release number of selected component (if applicable): 
strace-4.4.99 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
0. 
gcc -Wall -Werror system.c -o system 
 
1. 
$ strace -V 
strace -- version 4.4 
$ strace -fF -o strace-4.4.log ./system 
Process 5072 attached 
Process 5071 suspended 
Process 5071 resumed 
Process 5072 detached 
 
2. 
$ strace -V 
strace -- version 4.4.99 
$ strace -fF -o strace-4.4.99.log ./system 
[here strace blocks indefinitely]
Comment 1 Dmitry V. Levin 2003-09-25 07:26:10 EDT
Created attachment 94710 [details]
system.c
Comment 2 Dmitry V. Levin 2003-09-25 07:26:58 EDT
Created attachment 94711 [details]
strace-4.4.99.log
Comment 3 Roland McGrath 2003-09-25 20:35:40 EDT
Are you using a kernel-2.2.5 rpm from somewhere, or what build exactly?
Comment 4 Dmitry V. Levin 2003-09-25 20:52:36 EDT
$ uname -r 
2.2.25-alt1-smp-secure 
 
It could be found at 
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/files/i586/RPMS/kernel22-smp-secure-2.2.25-alt1.i586.rpm 
 
I could try to test vanilla 2.2.25 or whatever else if required, but it will take some time. 
 
Since I had no problems like this with our 2.2.x kernels, I don't distrust the kernel. 
 
Comment 5 Dmitry V. Levin 2004-03-18 13:02:49 EST
I've localized the problem. 
strace snapshot 2002-12-31 passes the test, 
while strace v4_4_90 fails. 
 
Therefore the regression is due to the following change: 
 
2003-01-08  Roland McGrath  <roland@redhat.com> 
 
       * NEWS: Update for 4.4.90 test release. 
 
       Support for new Linux 2.5 thread features. 
[...] 
       Revamp -f support for Linux. 
[...] 
 
This change is quite big and non-trivial... 
 
Comment 6 Dmitry V. Levin 2005-08-16 13:25:33 EDT
sundaram@redhat.com, the problem still exists, so please do not mark it as
closed untill it is really fixed.
Comment 7 Rahul Sundaram 2005-08-29 04:43:28 EDT
Fedora Project currently maintains only Fedora Core 3 and Fedora Core 4.
Security updates for previous versions are available from http://fedoralegacy.org. 

Closing this again. Feel free to reopen if this is reproducible in maintained
versions of Fedora
Comment 8 Dmitry V. Levin 2005-08-29 13:48:30 EDT
Up to now, I was using RH's bugzilla to track all valid strace problems which is
necessary for normal strace maintenance.
I'm disappointed that now it is no longer possible as before.

Roland, do you have any ideas for better place of tracking strace bugs which do
not fit to Fedora project?

Note You need to log in before you can comment on or make changes to this bug.