Bug 1053581 - Wrong timezone guessing
Wrong timezone guessing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-15 07:52 EST by Jean Francois Martinez
Modified: 2014-01-21 04:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 12:59:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2014-01-15 07:52:43 EST
Description of problem:
Anaconda deduces timezone from langaueg.  Should use keyboard instead.  Many people, including me, whose native language is not English, prefer to use English as main distro language instead of dealing with inaccurate or bad translations along with glitschs when displaying non-AsII characters.  So if user selects US English as primary language it does not mean he lives in America.  The real clue is his keyboard.  Even for laptops: if he selects french keybord, it means the laptop has been bought in France and there is a 99,9% chance user lives in France.  So Anaconda should propose France's timezone not US Esast-Coast timezone.

Version-Release number of selected component (if applicable):
Everyone

How reproducible:
Always

Steps to Reproduce:
1.  Start installing
2.  Select US/English language and {French, German, Brasilian} keyboard
3.  

Actual results:
Anaconda preselects US East Coast timezone

Expected results:
Anaconda should preselect respoectively {FRance, Germany; Brazil} timezone

Additional info:
This is a minor point but one who has been going on for at least 10 years.
Comment 1 David Shea 2014-01-16 12:59:03 EST
(In reply to Jean Francois Martinez from comment #0)
> Expected results:
> Anaconda should preselect respoectively {FRance, Germany; Brazil} timezone

Those are two different time zones. If you include all of the French overseas departments and territories, those are twelve different timezones. Probably more, depending on what DST rules everyone uses. Anaconda currently attempts to use geoip data and the selected locale to determine a reasonable default for the time zone settings. The keyboard selection has some relation to territory, but it does not add significant data to those two pieces of information. We are not going to do this.
Comment 2 Jean Francois Martinez 2014-01-16 14:36:04 EST
Of course these are two different time zones.  Did you notice I said _respectively_?  It means if if user tells he has French keyboard then he is probably lives in France (overseas territories have only 1% of its population), if a German one the he probably lives in Germany and if a Brazilian one he probably lives in Brazil.  This is more accurate as GeoIP (BTW, what if user configures TimeZone before networking?) as on laptops user could be on travel.

About GeoIP.  Last two times I made a whole installation of Fedora it was on a machine who was not connected to a network

Please I am not telling you to rush to fix it since this is just a minor annoyance, I just ask you to put the idea "guessing timezone basing on keyboard or keyboard+GeoIp instead of language+GeoIP" in the requirements for the day there is major overhaul/rewrite from scratch of the installation program.,  Right?
Comment 3 Martin Kolman 2014-01-17 06:28:42 EST
(In reply to Jean Francois Martinez from comment #2)
> Of course these are two different time zones.  Did you notice I said
> _respectively_?  It means if if user tells he has French keyboard then he is
> probably lives in France (overseas territories have only 1% of its
> population), if a German one the he probably lives in Germany and if a
> Brazilian one he probably lives in Brazil.  This is more accurate as GeoIP
> (BTW, what if user configures TimeZone before networking?) as on laptops
> user could be on travel.
As we have a sort of a policy not to change options the user might have already seen or changed, as such behavior would be very confusing.

So GeoIP lookup is done only when starting up the installation, using the automatically configured network connection. If there is no connectivity, the lookup is not done. So changing network settings does not trigger another lookup (the user is already in the main configuration hub, so he can as well just configure the timezone, changing it under his hands would be just confusing).

> 
> About GeoIP.  Last two times I made a whole installation of Fedora it was on
> a machine who was not connected to a network
> 
> Please I am not telling you to rush to fix it since this is just a minor
> annoyance, I just ask you to put the idea "guessing timezone basing on
> keyboard or keyboard+GeoIp instead of language+GeoIP" in the requirements
> for the day there is major overhaul/rewrite from scratch of the installation
> program.,  Right?
Comment 4 Vratislav Podzimek 2014-01-21 04:11:46 EST
Please see the following blog post with an explanation of how and why things work in the Anaconda installer:
http://blog-vpodzime.rhcloud.com/?p=11

Note You need to log in before you can comment on or make changes to this bug.