Bug 10539 - Fdisk appears non-functional during install of RH 6.2 Intel
Fdisk appears non-functional during install of RH 6.2 Intel
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-03 08:55 EDT by Steve Falco
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-12 06:43:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Falco 2000-04-03 08:55:14 EDT
Hi - I believe there is a bug in the RH 6.2 Intel installation.  I have
tried normal, text, and expert modes.  In all cases, if I attempt to use
fdisk, the installation process either hangs or fails.

There is a work-around - simply hitting <ALT>-F2 allows me to run fdisk
manually from the bash prompt (although it did take a little while to
realize that the device files were in /tmp rather than /dev :-).

I noticed that the new fdisk in RH 6.2 requires different command-line
options than did previous versions.  Perhaps the installation scripts
were not modified to account for this?

If you would like any further information please contact me.
Incidentally, I did run md5sum on the iso file before I burned the CDROM
- it was correct, so I am confident that this is a real bug and not a
download glitch.
Comment 1 Tim Waugh 2000-04-11 07:18:59 EDT
When it hangs, is there anything interesting on virtual consoles 1, 2 or 4?
When it fails, what's the error message?
What are the command-line differences that you think might be tripping it up?
Comment 2 Tim Waugh 2000-04-12 06:43:59 EDT
Reporter was unable to reproduce.
Comment 3 mark.pleasance 2000-06-29 16:52:11 EDT
Actually, I'm experiencing the same problem.  I can reproduce(I've tried three 
times now)  fdisk hangs in the exact same place, (text and gui) setup 
(I haven't tried expert mode, or checked messages on virtual consoles . . .)

Hardware
Intel ISP2150 2U Rack Server Platform 
(http://www.intel.com/network/products/isp2150.htm#DataSheet)
(http://www.intel.com/network/tech_specs/isp2150.htm)
PIII 550MHz, 256Mb, Western Dital 9.1 Gb 10K RPM - Ultra2 LVD SCSI (MD# WD91FH-
00ASA0,)SCSI BIOS enabled.

From previous comments . . .
When it hangs, is there anything interesting on virtual consoles 1, 2 or 4?
Unknown, haven't checked.  Will check next time I perform install (tomorrow.)

When it fails, what's the error message?
No error message, fdisk reports attempting to create /tmp... and hangs (I left 
it for over an hour during one install.)

What are the command-line differences that you think might be tripping it up?
No idea - just trying to be helpful, but not that versed in fdisk command 
arguments.
Comment 4 mark.pleasance 2000-06-30 10:07:38 EDT
Virtual Console 1
"You selected row 125.  More specifically you clicked in column1, and the text 
in this cell is American/Nipigon"
Virtual Console 2
"bash#"
Virtual Console 4 - multiple timeouts.
<4>scsi : aborting command due to timeout : pid 376, scsi0, channel 0, id 0, 
lun0, Write (10) 00 00 84 a0 cd 00 00 80 00
<4>SCSI host 0 abort (pid399) timed out - resetting
<4>SCSI bus is being reset for host 0 channel 0. 
<6>(scsi0:0:0:0) Syncrhronous at 80.0 Mbyte/sec, offset31."
etc . . .

Virtual Console 7
display window with "Formatting /home filesystem"  (with no change)

Hope this helps, please feel free to contact me via e-mail.
mark.pleasance@q9.com

Note You need to log in before you can comment on or make changes to this bug.