Bug 10540 - Domain Logins on Samba do not work
Summary: Domain Logins on Samba do not work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-03 13:06 UTC by David Herselman
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 18:14:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Herselman 2000-04-03 13:06:01 UTC
I can browse the shares by going to \\server but I can not perform domain
logins. The Windows 95 and Windows 98 clients get 'No Domain Server found'
error message.

/etc/hosts:
127.0.0.1    localhost.localdomain  localhost
192.168.1.1  server  server.hersch.co.za  hersch.co.za

/var/log/samba/log.nmb:
[2000/04/03 13:25:00, 0] libsmb/nmblib.c:send_udp(754)
  Packet send failed to 192.168.1.5(138) ERRNO=Invalid argument

/etc/rc.d/rc.local additions:
/sbin/ipfwadm-wrapper -A -f
/sbin/ipfwadm-wrapper -A -i -S 192.168.1.1/32 -D 0.0.0.0/0
/sbin/ipfwadm-wrapper -A -i -S 0.0.0.0/0 -D 192.168.1.1/32
/sbin/ipfwadm-wrapper -A -i -S 192.168.1.0/24 -D 0.0.0.0/0
/sbin/ipfwadm-wrapper -A -i -S 0.0.0.0/0 -D 192.168.1.0/24

# Start IP Masquerading
/sbin/ipchains -P forward DENY
/sbin/ipchains -A forward -s 192.168.1.0/24 -j MASQ
/sbin/ipchains -M -S 3600 0 0
/sbin/depmod -a
/sbin/modprobe ip_masq_ftp
/sbin/modprobe ip_masq_irc
/sbin/modprobe ip_masq_quake
/sbin/modprobe ip_masq_raudio
/sbin/modprobe ip_masq_vdolive

/etc/smb.conf:
[global]
   protocol = NT1
   announce as = NT
   announce version = 4.2
   server string = Server in Hersch

   os level = 33
   debug level = 1
   max log size = 50
   guest account = pcguest
   socket options = TCP_NODELAY
   name resolve order = wins bcast host lmhosts

   workgroup = Hersch
   netbios name = Server
   admin users = root, davidh
   interfaces = 127.0.0.1/255.255.255.0 192.168.1.1/255.255.255.0

   logon script = netlink.bat
   lock directory = /var/lock
   username map = /etc/smbusers
   log file = /var/log/samba/log.%m
   smb passwd file = /etc/smbpasswd

   min passwd length = 0
   passwd chat debug = no
   unix password sync = yes
   passwd program = /usr/bin/passwd --stdin %u
   passwd chat = *Changing* %n\n *all*updated*successfully*

   status = yes
   dns proxy = yes
   mangle case = no
   time server = yes
   wins support = yes
   mangled names = yes
   dos filetimes = yes
   preserve case = yes
   case sensitive = no
   default case = lower
   read prediction = yes
   short preserve case = yes

   security = user
   local master = yes
   domain logons = yes
   domain master = yes
   preferred master = yes
   encrypt passwords = yes

   printing = bsd
   load printers = yes
   printcap name = /etc/printcap

[nobody]
   path = /dev/null
   comment = Blocked Access on Server
   guest ok = no
   browseable = no
   writeable = no
   printable = no

[netlogon]
   path = /home/samba/netlogon
   comment = Network Logon Service on Server
   guest ok = yes
   browseable = no
   writeable = no
   printable = no
   write list = @root
   create mode = 0644
   directory mode = 0755

[cd]
   path = /mnt/cdrom
   comment = CD on Server
   guest ok = no
   browseable = yes
   writeable = no
   printable = no
   write list = @root
   valid users = @root, @users
   create mode = 0640
   directory mode = 0750
   force group = users

[read]
   path = /home/samba/read
   comment = Read only on Server
   guest ok = no
   browseable = yes
   writeable = no
   printable = no
   write list = @root
   valid users = @root, @users
   create mode = 0660
   directory mode = 0770
   force group = users

[public]
   path = /home/samba/public
   comment = Public on Server
   guest ok = no
   browseable = yes
   writeable = no
   printable = no
   write list = @root, @users
   valid users = @root, @users
   create mode = 0660
   directory mode = 0770
   force group = users

[homes]
   comment = User Directory on Server
   guest ok = no
   browseable = no
   writeable = yes
   printable = no
   valid users = %S
   create mode = 0600
   directory mode = 0700
   force group = users

[hp220]
   path = /tmp
   comment = Hewlett Packard DesignJet 220 on Server
   guest ok = no
   browseable = yes
   writeable = no
   printable = yes
   printer name = hp220
   write list = @users
   create mode = 0700

Comment 1 Trond Eivind Glomsrxd 2001-06-18 15:57:49 UTC
Is this still a problem with newer samba versions, like samba-2.0.8-1.6 (the
latest samba errata for Red Hat Linux 6.x)?

Comment 2 Trond Eivind Glomsrxd 2001-08-09 18:14:52 UTC
ping?

Comment 3 Trond Eivind Glomsrxd 2001-11-29 17:13:24 UTC
Closing due to lack of feedback - I assume it works with the current releases,
at least.


Note You need to log in before you can comment on or make changes to this bug.