Bug 105626 - LTC4534-LinuxIA64 complains about unaligned accesses on the tty.
LTC4534-LinuxIA64 complains about unaligned accesses on the tty.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Geoff Gustafson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-25 23:56 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 15:45:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-09-25 23:56:14 EDT
The following has be reported by IBM LTC:  
LinuxIA64 complains about unaligned accesses on the tty.
Hardware Environment:
IA64 hardware

Software Environment:
DB2 V8.1

Steps to Reproduce:
1. Run DB2 and the following messages appear:
db2sysc(28177): unaligned access to 0x200000000a9d0085, ip=0x2000000002d21421
db2sysc(28177): unaligned access to 0x200000000a9d0085, ip=0x2000000002d213d0
db2sysc(28177): unaligned access to 0x200000000a9d0085, ip=0x2000000002d21421
db2sysc(28177): unaligned access to 0x200000000a9d0085, ip=0x2000000002d213d0
db2sysc(28177): unaligned access to 0x200000000a9d0085, ip=0x2000000002d21421

Expected Results:
These messages can be put into /var/log/messages, but they should not show up 
on the screen.  We realize DB2 has some unaligned accesses, but we can't 
correct them completely due to issues with compatibility with our own products.

Additional Information:
I'd like to request that the write message to the tty be commented out in the 
kernel for the final Release of RHEL 3.Greg/Glen - Please submit this to Red
Hat.  Looks like a reasonable request.
Thanks.
Comment 1 Bill Nottingham 2003-09-26 00:00:56 EDT
prctl --unaligned=silent <process> will make the errors go away.
Comment 2 IBM Bug Proxy 2003-09-26 00:15:51 EDT
------ Additional Comments From khoa@us.ibm.com  2003-26-09 00:09 -------
Yvonne - does Red Hat's suggestion above work for you ?  If not, please
re-open this bug report.  Thanks. 
Comment 3 Arjan van de Ven 2003-09-26 03:18:15 EDT
Unfortionatly this is a hot issue (see this weeks lkml flamewar ;) and the
upstream IA64 maintainer is very very insistent on this default behavior.
Comment 4 IBM Bug Proxy 2003-09-26 10:42:46 EDT
------ Additional Comments From yvchan@ca.ibm.com  2003-26-09 09:06 -------
I believe that command is a per process command.  I can't expect our customers 
to run that everytime they start DB2 up, and for every process. Is there a 
better way to do this?  

The reason I make the suggestion that I do, is that DB2 is not the only app 
that still has unaligned accesses on Itanium.  It would be more prudent to take 
the tty_write call out, and just leave the printk in. 
Comment 5 IBM Bug Proxy 2003-09-26 14:36:15 EDT
------ Additional Comments From yvchan@ca.ibm.com  2003-26-09 14:33 -------
Please leave this as an open bug to be re-visited when we look at the 
Errata/Service Release 1 for RHEL 3. 
Comment 6 IBM Bug Proxy 2003-10-03 10:58:38 EDT
------ Additional Comments From khoa@us.ibm.com  2003-03-10 10:05 -------
OK, I will set the resolution of this bug to "Will_Fix_Later" then. 
Comment 7 IBM Bug Proxy 2003-10-03 10:59:13 EDT
------ Additional Comments From khoa@us.ibm.com  2003-03-10 10:05 -------
We'll raise this issue again after RHEL3 GA. 
Comment 9 Tim Chambers 2004-03-31 16:01:48 EST
FWIW, I recently filed a bug against a SUSE product complaining about
unaligned accesses spewing to the console. The next day it was
unceremoniously marked as fixed.
Comment 10 IBM Bug Proxy 2005-06-21 13:56:37 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
          QAContact|khoa@us.ibm.com             |mranweil@us.ibm.com




------- Additional Comments From mranweil@us.ibm.com  2005-06-21 13:51 EDT -------
Ok, we never brought this up after rhel3, and now we're into rhel4.  The bugs
still open on RH's side...

Yvonne - and idea if this is still an issue?  After this long you've learned how
to live with it?  Any suggestions on what to do? 
Comment 11 Jason Baron 2005-06-21 14:01:29 EDT
The 'unaligned access' are not coming from the kernel, otherwise the lines would
say: 'kernel unaligned access'. Thus, this is a problem with the db2sync
program. If this is not a RH issue we should probably close this.
Comment 12 IBM Bug Proxy 2005-09-07 13:29:10 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REJECTED                    |CLOSED




------- Additional Comments From yvchan@ca.ibm.com  2005-09-07 13:26 EDT -------
Closing 
Comment 13 Ernie Petrides 2005-09-12 15:45:04 EDT
Closing per last comment.

Note You need to log in before you can comment on or make changes to this bug.