Bug 105666 - X-CDroast/cdrecord fails, sometimes locks system
X-CDroast/cdrecord fails, sometimes locks system
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 09:19 EDT by leganza
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-28 08:02:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leganza 2003-09-26 09:19:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Name        : xcdroast                     Relocations: (not relocateable)
Version     : 0.98a13                           Vendor: Red Hat, Inc.
Release     : 4                             Build Date: Sat 25 Jan 2003 05:26:57
PM KST
Install Date: Sat 19 Apr 2003 01:09:42 AM KST      Build Host:
porky.devel.redhat.com


Name        : cdrecord                     Relocations: (not relocateable)
Version     : 2.0                               Vendor: Red Hat, Inc.
Release     : 11.9.1                        Build Date: Mon 04 Aug 2003 08:28:11
PM KST
Install Date: Tue 19 Aug 2003 08:52:14 AM KST      Build Host: daffy.perf.redhat.com


X-CDroast/cdrecord used to work fine, although it's been a few months since I
used it.

Now it always fails and sometimes freezes the system - keyboard/mouse dead, only
power-off switch responds.  Other times it gives the below error lines.

System is fully patched RH9 on P4 1.7G, ASUS P4T, SCSI HDs & CD-R, Plextor CD-RW
is IDE.

Nothing has changed in the hardware or CDroast config since the initial setup. 
RedHat updates were applied as published.



From cdrecord.out -

Calling: /usr/lib/xcdroast-0.98/bin/xcdrwrap CDRECORD dev=1,0,0 gracetime=2
fs=4096k driveropts=burnfree -v -useinfo speed=16 -dao -eject -pad -data
"/opt/fire-0.4a.iso" ...
 
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
Linux sg driver version: 3.1.24
pregap1: -1
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.7'
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PX-W4012A'
Revision       : '1.02'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE VARIREC
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 4194304 = 4096 KB
FIFO size      : 4194304 = 4096 KB
cdrecord: Drive needs to reload the media to return to proper status.
Track 01: data   578 MB         padsize:   30 KB
Total size:      664 MB (65:50.49) = 296287 sectors
Lout start:      664 MB (65:52/37) = 296287 sectors
Current Secsize: 2048
ATIP info from disk:
Indicated writing power: 5
Is not unrestricted
Is not erasable
Disk sub type: Medium Type A, low Beta category (A-) (2)
ATIP start of lead in:  -11634 (97:26/66)
ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Trying to clear drive status.
Starting to write CD/DVD at speed 16 in real SAO mode for single session.
cdrecord: Input/output error. read track info: scsi sendcmd: no error
Waiting for reader process to fill input buffer ... input buffer ready.
CDB:  52 01 00 00 00 FF 00 00 1C 00
BURN-Free is ON.
status: 0x2 (CHECK CONDITION)
Performing OPC...
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 24 00 00 00
Sending CUE sheet...
Sense Key: 0x5 Illegal Request, Segment 0
Writing pregap for track 2 at -150
Sense Code: 0x24 Qual 0x00 (invalid field in cdb) Fru 0x0
write track pad data: error after 0 bytes
Sense flags: Blk 0 (not valid)
BFree: 2338 K BSize: 2338 K
cmd finished after 0.000s timeout 240s
Starting new track at sector: 0
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 FF FF FF 6A 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 27 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x27 Qual 0x00 (write protected) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 200s
cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 00 00 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 27 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x27 Qual 0x00 (write protected) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 200s
                                                                               
                                       
Sense Bytes: 70 00 00 00 00 00 00 0A 00 00 00 00 00 00 00 00 00 00
write track data: error after 0 bytes
Writing  time:    5.019s
Average write speed 788.5x.
Fixating...
Fixating time:    0.000s
cdrecord: fifo had 64 puts and 1 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The usual steps for X-cdroast: Create CD > Write Tracks > Layout tracks > Add
[image of choice] > Accept track layout > Write Tracks

Insert CD > OK

Status Windows pops up and it begins normally.



    

Actual Results:  It stalls on this line, "Performing OPC...", hangs there a
while, and eventually fails.  Sometimes system locks up, hard.

Expected Results:  CD write success.

Additional info:...........................
Comment 1 Harald Hoyer 2003-10-24 08:52:01 EDT
seems to be a kernel problem... does it happen with the latest errata kernels also?
Comment 2 leganza 2003-10-25 02:47:49 EDT
Yes it did, uname -r = 2.4.20-20.9

A couple week ago RedHat responded to my initial report and ask that I try it
with megic-dev and autorun disabled.

I did so, and was able to burn again :-)

I replied as such to Bugzilla, but those and RedHat's earlier comments are gone
now???
Comment 3 Harald Hoyer 2003-10-28 08:02:49 EST
yeah, the harddrive of bugzilla crashed... so, they got lost :-/

Note You need to log in before you can comment on or make changes to this bug.