Bug 105715 - evolution is very unstable
evolution is very unstable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 105640 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 15:43 EDT by Florent B
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-07 19:19:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florent B 2003-09-26 15:43:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
evolution is very unstable and often crash.

PS : the meteo is for Boston, I have selected Europe/Monaco in the wizard.

Version-Release number of selected component (if applicable):
1.4.4-7

How reproducible:
Sometimes

Steps to Reproduce:
1. launch evolution
2. use it
3.
    

Additional info:
Comment 1 petrosyan 2003-09-26 19:29:05 EDT
evolution freezes on me all the time.

for all practical purposes evolution has become unusable.

Comment 2 Noa Resare 2003-09-27 09:51:15 EDT
One easily reproducible test case:

1. Create a new account test0
2. Log into the account and start evolution
3. Go through the welcoming wizard selecting no incoming mail source
4. When the summary window (Sammanfattning in swedish) shows after the wizard
has finished it freezes with no repaints.

I have reproduced this behaviour on two vanilla severn2 boxes
Comment 3 Kevin Brouelette 2003-09-27 16:15:29 EDT
Evolution 1.4.4 from Fedora test2
I originally rebooted and then checked bugzilla after it happens
regularly.   

killall -9 evolution-wombat

seems to get control back so I can use Evolution again.
if I Tools-Settings it hangs again and 
killing evolution-wombat gains control again.
Can someone confirm they can recover the same way.


Comment 4 Noa Resare 2003-09-28 06:59:08 EDT
The particular freeze I mentioned above is curable by killing evolution-wombat.
What is more interesting is a strace on the evolution-wombat, that turns out
like this:

[test0@molly test0]$ strace -p 5886
Process 5886 attached - interrupt to quit
futex(0x8e1b2f8, FUTEX_WAIT, 2, NULL <unfinished ...>

Looks like an nptl related problem to me.
Comment 5 James Drabb 2003-09-28 18:26:40 EDT
I have been having the same problems.  Evolution under Severn 0.94 is NOT usable
at all.  However, I just ran evolution as:

 LD_ASSUME_KERNEL=2.4.1 evolution

And it seems stable now.  So most likely an NPTL problem with evolution-wombat?
Comment 6 Florent B 2003-09-29 04:08:14 EDT
For info, Evolution 1.4.5 is out : 
 
http://developer.ximian.com/projects/evolution/release_notes/1.4.5.html 
Comment 7 Noa Resare 2003-09-29 04:40:16 EDT
I've tested evolution-1.4.5 on my machine, and it exhibits the same "freeze on
futex()" behaviour as the evolution-1.4.4-7 in severn2
Comment 8 Jeremy Katz 2003-10-06 16:06:23 EDT
*** Bug 105640 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2003-10-06 16:07:14 EDT
Can you see if the ORBit2 cvs snap at http://people.redhat.com/~katzj/ORBit2/
helps any?
Comment 10 Noa Resare 2003-10-06 16:43:25 EDT
I can confirm that the upgrade (ORBit2-2.8.1.90-1) fixes the problems I've had.
The test case above (with a new system user) no longer produces a hang.
Comment 11 Bruce A. Locke 2003-10-07 19:06:41 EDT
evolution no longer seems to hang on start and otherwise misbehave since
updating to ORBit2-2.8.1.90-1
Comment 12 Derrik Pates 2003-10-09 16:39:51 EDT
Does anyone else still see a problem when, if there are still open connections
(like in the case of IMAP mail), and you tell Evolution to go offline, Evolution
either segfaults or gives an assert error in ORBit_POA_setup_root (), and dies?
I'm seeing this with GNOME 2.4 on both PowerPC and i386. This is not with the
Rawhide/Fedora packages, but the symptoms seem similar. This behavior has been
observed on both arches with the stock 2.8.1 ORBit and the 2.8.1.90 modified
source, as well as current ORBit2 CVS.

Note You need to log in before you can comment on or make changes to this bug.