Bug 10575 - packages duplicated, install scripts NOT executed
Summary: packages duplicated, install scripts NOT executed
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-04 09:43 UTC by cspeter
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-19 19:46:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log for clarisse (laptop) (78.77 KB, text/plain)
2000-07-19 19:44 UTC, borgia
no flags Details
upgrade.log for deunan (desktop) (56.86 KB, text/plain)
2000-07-19 19:46 UTC, borgia
no flags Details

Description cspeter 2000-04-04 09:43:47 UTC
(I'm not sure if it has anything to do with "anaconda")
I upgraded my RedHat 6.1 to 6.2 from cdrom. The system is crappy now,
although there was no error during the install.

1. Most packages are duplicated, not upgraded. For example (rpm -qa|sort):
...
kernel-source-2.2.12-20
kernel-source-2.2.14-5.0
...
rpm-3.0.3-2
rpm-3.0.4-0.48
...
tetex-1.0.6-11
tetex-1.0.6-7
tetex-dvips-1.0.6-11
tetex-dvips-1.0.6-7
tetex-fonts-1.0.6-11
tetex-fonts-1.0.6-7
tetex-latex-1.0.6-11
tetex-latex-1.0.6-7
tetex-xdvi-1.0.6-11
tetex-xdvi-1.0.6-7
texinfo-3.12h-2
texinfo-4.0-5
textutils-2.0-2
textutils-2.0a-2
...
This bug is not new, it caused me headaches with earlier RedHat releases
also.

2. Some (maybe all?) install scripts are NOT executed:
- After rebooting, the old kernel (2.2.12) worked instead of the new,
because the /boot/vmlinuz, etc. symlinks in /boot did NOT change.
- programs using kerberos libs (pine for example) don't work because
/usr/kerberos/lib is not in /etc/ld.so.conf


A possible explanation:
At first, I accidentally choose "Install" instead of "Upgrade". I noticed
it a bit later when it wanted to fdisk. So I went back to the
Install/Upgrade choice, and choose "Upgrade". But the setup program may
have also rembered my first choice because of some bug in it.

I think the setup program should *always* rpm -U and *never* rpm -i. So it
would be less sensitive to such bugs.

Comment 1 borgia 2000-07-17 18:46:18 UTC
After upgrading to beta3, the following packages are duplicated: sendmail, apache, kdesupport. System was restored by removing and 
reinstalling the offending packages.


Comment 2 Matt Wilson 2000-07-18 14:34:34 UTC
Send the output of /tmp/upgrade.log.  If the %pre script fails on a package
install or the %postunpre fails on a package remove they are not
installed/removed.


Comment 3 borgia 2000-07-19 19:44:26 UTC
Created attachment 1328 [details]
upgrade.log for clarisse (laptop)

Comment 4 borgia 2000-07-19 19:46:08 UTC
Created attachment 1329 [details]
upgrade.log for deunan (desktop)

Comment 5 Andrea Borgia 2000-08-09 12:24:12 UTC
Installed two 6.2 test boxes and upgraded both to Pinstripe.
Didn't happen.
Come on, who fixed it? ;-)



Note You need to log in before you can comment on or make changes to this bug.