Bug 105766 - SRPM retrieval progress output looks a bit ugly sometimes
SRPM retrieval progress output looks a bit ugly sometimes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-27 04:23 EDT by Barry K. Nathan
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-17 14:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2003-09-27 04:23:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030919

Description of problem:
Sometimes, when up2date is downloading source RPMs, it seems to mess up the
progress display a bit.

Version-Release number of selected component (if applicable):
up2date-3.9.29-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Configure up2date to always retrieve source RPMs along with the binaries.
2. up2date -ui some-rpm-thats-not-on-the-system
3. Profit?
    

Actual Results:
[root@localhost root]# up2date unixODBC-kde
                                                                                
Fetching package list for channel: rhel3-beta1-ws-i386...
########################################
                                                                                
Fetching Obsoletes list for channel: rhel3-beta1-ws-i386...
                                                                                
Fetching rpm headers...
########################################
                                                                                
Name                                    Version        Rel
----------------------------------------------------------
unixODBC-kde                            2.2.3          6                   i386
                                                                                
 
 
Testing package set / solving RPM inter-dependencies...
########################################
unixODBC-kde-2.2.3-6.i386.r ########################## Done.
unixODBC-2.2.3-6.src.rpm:    Preparing             
########################################### [100%]
 
Installing...
   1:unixODBC-kde           ########################################### [100%]
[root@localhost root]#


Expected Results:

Even if you're not going to bother having a thermometer bar for the retrieval of
unixODBC-2.2.3-6.src.rpm, it'd be nice to see a "100%" or something like that
show up when it's done downloading. **At least** print a newline so that
"Preparing..." doesn't get wrapped between two lines (that's the real ugliness).

(If I had downloaded multiple packages. other progress bars and not just
"Preparing..." would probably be wrapped like this.)

Additional info:

This ugliness doesn't seem to always happen. I'm not sure when it happens and
when it doesn't. My best guess is that it only happens if the SRPM didn't get
downloaded by up2date already (i.e., for installing a different binary RPM) but
I'm not completely sure about that.

I should have reported this earlier in the beta cycle. Sorry about that. If it's
too late to fix this, personally that doesn't bother me.
Comment 1 Adrian Likins 2003-09-29 12:09:01 EDT
are you using dir based repos?

fixed a bug similar to this for dir repoes around .30 or so...
Comment 2 Barry K. Nathan 2003-09-29 12:40:46 EDT
No, this is RHN.
Comment 3 Adrian Likins 2003-11-04 15:51:40 EST
cleaned up some of this along the beta, and cant seem to
reproduce it now. (with 4.1.18 at least...)

If it's still happening, reopen.
Comment 4 Barry K. Nathan 2004-04-17 14:58:28 EDT
Looks like you left the bug open. But, it seems fixed to me too (sorry
I took so long to verify that), so I'm closing it.

Note You need to log in before you can comment on or make changes to this bug.