Bug 105816 - samba client in nautilus does not work
Summary: samba client in nautilus does not work
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-28 03:55 UTC by Dan
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 19:30:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan 2003-09-28 03:55:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I can not see my windows shares in nautilus with test 2 was able to with   test
1 + rawhide up until I installed test 2 over it.  When I click on the network
servers icon in the menu and when I type smb:/// in the nautilus address bar. I
get this message:
"Couldn't display "smb:///", because Nautilus cannot contact the SMB master browser.
Check that an SMB server is running in the local network."

Version-Release number of selected component (if applicable):
samba-client-3.0.0-5rc1

How reproducible:
Always

Steps to Reproduce:
1.click redhat menu
2.click on "Network Servers"
3.see message come up: "Couldn't display "smb:///", because Nautilus cannot
contact the SMB master browser.
Check that an SMB server is running in the local network."

    

Actual Results:  I see an message saying:
"Couldn't display "smb:///", because Nautilus cannot contact the SMB master browser.
Check that an SMB server is running in the local network."
and I can not see any of my windows shares

Expected Results:  I should be able to see my windows machine and the folder
that is being shared

Additional info:

Comment 1 Jay Fenlason 2003-09-29 14:57:55 UTC
This sounds like a nautilus bug, so I'm reassigning it to the nautilus maintainer.  
Also, this bug will be far easier to reproduce if you attach a copy of your 
/etc/samba/smb.conf file for the machine running nautilus, and describe your 
Windows network topology (domain or workgroup, what oses (and Service Pack 
levels) you're running, etc. 

Comment 2 Dan 2003-09-29 19:06:13 UTC
I'm in a small home workgroup just the linux box plus a windows 2000 sp4 machine
that holds my backed up data for when I test these test releases.  As for the
/etc/samba/smb.conf file it should be what came as default as I had not modified
that file.  Perhaps the problem may be the name of the workgroup is not
matching, but as I said it worked before with redhat 9, test 1, and test 1 +
rawhide without modifing the /etc/samba/smb.conf file. Let me test that theory
out and I'll get back to you.

Comment 3 David Lawrence 2003-09-29 19:12:55 UTC
This can happen (and happens to me alot) if you have your firewall turned on or
not configured to pass smb traffic. Try doing as root "service iptables stop"
and then try to browse for shares. Let us know is this helps.


Comment 4 Dan 2003-09-29 19:19:05 UTC
ok I disabled the firewall and it works now.
One question what port does samba use so I can have my firewall enabled again?

Comment 5 David Lawrence 2003-09-29 19:26:29 UTC
http://us1.samba.org/samba/devel/docs/html/Samba-HOWTO-Collection.html#id2901029

UDP/137 - used by nmbd
UDP/138 - used by nmbd
TCP/139 - used by smbd
TCP/445 - used by smbd

Please close this bug report as NOTABUG if satisfactory.
Thanks.

Comment 6 Dan 2003-09-29 19:30:07 UTC
ok cool thanks you guys.


Note You need to log in before you can comment on or make changes to this bug.