Bug 105822 - Suggestions for "Internet" Menu structure
Suggestions for "Internet" Menu structure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Nickell
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 01:01 EDT by Bruce A. Locke
Modified: 2014-01-30 13:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 15:58:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce A. Locke 2003-09-28 01:01:03 EDT
The current contents of my "Internet" Menu:

"Evolution Email"
"Messaging Client"
"Mozilla Web Browser"
"Video Conferencing"

In the "More Internet Applications" submenu:

"ethereal"
"gFTP"
"IRC Client"
"Konqueror Web Browser"
"Mozilla Mail Message"
"Mozilla Mail"
"Pan"


There are three things that catch my eye:

1. Some items have the program name in the item name while others do not

I guess this can be excused since item names have to be kept short.

2. Some items are descriptive while others are not

This probably isn't a good idea from a UI standpoint...

3. Mozilla Mail appears twice (for me anyway)


Suggestions:

"Pan" -> Pan News Reader
"gFTP" -> File Transfer Client  (not just FTP since it also supports sftp)
"ethereal" -> Network Analyzer (or at least make the E in "Ethereal" capital)

I'm personally not married to these suggestions but I think its something that
should be looked at.

Comments?
Comment 1 Jones Lee 2004-04-05 17:37:32 EDT
Yes, I agree with your opinion, we should change the structure to make
it more manageable.
Comment 2 Bryan W Clark 2004-11-02 15:58:22 EST
(In reply to comment #0)
The new menus should look like this:
 
> "Evolution Email"
> "IM"
> "Firefox Web Browser"
> "Video Conferencing"
> "IRC"

> In the "More Internet Applications" submenu:

This should not appear on a default desktop install.

> "ethereal"
I believe this has been moved to System Tools as "Ethereal Network Analyzer"

> "gFTP"
Not installed by default, should be something like "File Transfer Client"

> "IRC Client"
In Main menu

> "Konqueror Web Browser"
Not installed by default, but looks correct

> "Mozilla Mail Message"
> "Mozilla Mail"
These should not appear anymore

> "Pan"
Not installed by default, should be "Pan News Reader"

Thanks for the suggestions.  If these problems persist in the latest release
please file bugs against each component.

Note You need to log in before you can comment on or make changes to this bug.