Bug 105834 - bad source code
bad source code
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 06:56 EDT by d.binderman
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 04:33:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-09-28 06:56:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package kdebase-3.1-12, from Redhat 9.0,
with compiler flag -Wall.

The compiler said

protocol.cpp:163: warning: return-statement with no value, in function declared
with a non-void return type

This looks like something worth fixing to me



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with flag -Wall
2.
3.
    

Additional info
Comment 1 Rik van Riel 2004-10-13 16:16:19 EDT
Chances are this one's been fixed long ago, too ;)
Comment 2 Ngo Than 2004-10-14 04:33:56 EDT
it's already fixed in RHEL3 and FC2 current release.

Note You need to log in before you can comment on or make changes to this bug.