Bug 105855 - Even basic window sizing is now mishandled by Metacity
Even basic window sizing is now mishandled by Metacity
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 10:18 EDT by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 13:36:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2003-09-28 10:18:14 EDT
Metacity has always had problems with automatic size limiting and things like
the panel. The version in severn still has all of these nasty bugs and another
even worse one

Open a terminal window, place it at the top of the screen
Drag the bottom downwards, it goes behind the panel
Now try getting it back without using magic keypresses or reconfiguring the panel

Metacity has always had too many traps for its alleged target audience, this one
exceeds the others by a large margin.

Metacity's inability to do basic window sizing needs fixing properly, and
preferably before Fedora release, especially the bad bugs like this
Comment 1 Havoc Pennington 2003-09-28 21:27:42 EDT
Thank you for the lecture, I hadn't noticed the bugs should be fixed.

Go into src/constraints.c and help me with the math, if you want to help.
Comment 2 Havoc Pennington 2003-09-28 21:37:57 EDT
That said, I can't reproduce the problem. You are saying the titlebar goes under
the top panel or you can move the bottom edge of the terminal below the bottom
panel?

I assumed the former, however it doesn't happen to me.
The latter (able to move bottom edge below the bottom panel) is intended
behavior at the moment. It's also always been the behavior as far as I remember.
The constraint is "menu button on top-left of titlebar is onscreen" basically
and has been forever, the implementation just keeps getting modified.

Re: your generalizations, the only other bug I know of from you is "does not
force windows to fit on screen at map time." Also, 2.6.x does fix several bad
resize bugs. One can be reproduced in 2.4.x by pushing a window against the top
of the screen and resizing it from the top edge. Another by trying to resize a
window with no minimum size. Another by trying to use window gravities. The
primary bug introduced by the new code is some keyboard resize funkiness,
especially with terminals; and some problems with certain apps resizing themselves.
Comment 3 Josh Douglas 2003-10-02 14:11:10 EDT
It seems to me to be undesirable behavior. Why would there be a reason to resize
a window to extend below the panel?
Comment 4 Havoc Pennington 2004-11-03 13:36:05 EST
Not sure what is still left here. Please file new bugs on specific
issues if any remain in FC3.
Comment 5 Alan Cox 2004-11-09 08:25:12 EST
Ok I'll open a new one because its all stil broken in FC3, just like
the focus handling.

Note You need to log in before you can comment on or make changes to this bug.