Bug 105862 - neat crashes when applying DNS changes
neat crashes when applying DNS changes
Status: CLOSED DUPLICATE of bug 75266
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 11:42 EDT by A J Kroon
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A J Kroon 2003-09-28 11:42:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
When I start neat, I switch to the DNS tab, enter one or more IP addresses and
click Apply, I get the following dump:

--

Traceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 60,
in network
    return re.match("NETWORK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'

--

and neat crashes. The system asks me to file a bug using the text above. When I
then restart neat, the DNS settings have not changed.

This is the output of route -n:

--

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
10.0.0.0        0.0.0.0         255.0.0.0       U     0      0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         10.0.0.2        0.0.0.0         UG    0      0        0 eth1

--

192.168.1.0 is our local network, 10.0.0.0 is our (external) ADSL network. The
IP address on eth1 is 10.0.0.85. The ADSL router has IP address 10.0.0.2. At the
moment 10.0.0.2 is registered as the only DNS; this needs to change.

Version-Release number of selected component (if applicable):
???

How reproducible:
Always

Steps to Reproduce:
1. Start neat
2. Switch to the DNS tab
3. Enter 1, 2 or 3 IP addresses
4. Click Apply


Actual Results:  I get the dump as shown in the description

Expected Results:  I expected the DNSs to be accepted.

Additional info:

See the description
Comment 1 Harald Hoyer 2004-09-21 08:10:16 EDT

*** This bug has been marked as a duplicate of 75266 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.