Bug 105885 - metacity seems to mishandle the "Hide all windows and focus desktop" thing
metacity seems to mishandle the "Hide all windows and focus desktop" thing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 20:05 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 15:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dams 2003-09-28 20:05:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Galeon/1.3.9

Description of problem:
When i want to launch an application (for example, emacs) from a nautilus
desktop icon i often press ctrl-alt-d before i double-click on the emacs
nautilus icon in the desktop. This icon has been dragged from the main menu.
Then, the emacs window appear but all other windows on all desktop are now
iconified ! 
Pressing C-A-d again only hide the emacs window. Pressing C-A-d again will only
make the emacs window to re-appear. The desktop-list appplet seems to say that
the windows are *not* iconified. And, in shrike, when i was double-clicking on
the emacs desktop icon, all other windows would re-appear at the very same-time
than the emacs window..

Version-Release number of selected component (if applicable):
metacity(0:2.5.3-3).i386

How reproducible:
Always

Steps to Reproduce:
1. Drag an application (gnome-terminal, emacs, whatever..) from the menu and
drop it onto the desktop
2. be sure to have some windows opened on the current desktop
3. press C-A-d
4. double click (to open) on the application desktop icon.
    

Actual Results:  The application window is here, but all other windows are
iconified.

Expected Results:  The other windows should be restored.. 

Additional info:

System is fresh severn2 install + some fedora.us add-on.
Comment 1 Havoc Pennington 2003-09-28 21:44:17 EDT
See bugzilla.gnome.org bug #92335, I believe what you've described is the
intended behavior. Discussion of changing it again needs to be upstream.
Probably NOTABUG though unless there are small glitches outstanding in the exact
behavior.

Note You need to log in before you can comment on or make changes to this bug.