Bug 105898 - Japanese fonts no longer antialiased
Summary: Japanese fonts no longer antialiased
Status: CLOSED DUPLICATE of bug 97337
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-29 07:21 UTC by John Thacker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Thacker 2003-09-29 07:21:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030927

Description of problem:
In RHL 9, Japanese fonts were nice and antialiased.  Since upgrading to Fedora
Core test2 from RHL 9, Japanese fonts aren't antialiased.

Actually, from testing, it's a little more complicated than that.  The Arial MS
Unicode contains Japanese characters, and when it is used to display Japanese,
the characters are antialiased.  For all Japanese fonts, the characters become
antialiased (or look so) on certain point sizes, especially large ones.  When
using the MS Gothic font, the Roman alphabet characters are always antialiased,
but the Japanese characters are only antialiased at point sizes above 18.  With
MS Mincho, no characters are antialiased at any point size below 18, but all
characters are antialiased at all sizes 18 and above.  When using Kochi Gothic
and Kochi Mincho, the fonts are completely antialiased (testing with gedit) at
size 14, and at all sizes 18 and above, and not at all otherwise.

With RHL 9, all these fonts were antialiased at all different sizes.  They
looked a lot better.

Version-Release number of selected component (if applicable):
fontconfig-2.2.1-4

How reproducible:
Always

Steps to Reproduce:
1.  Install Japanese fonts.
2.  View something in Japanese.
3.  Observe fonts.
    

Actual Results:  Fonts are not antialiased, except at certain, especially large,
sizes

Expected Results:  Fonts should have been antialiased at all sizes, like in RHL 9.

Additional info:

Comment 1 John Thacker 2003-10-16 14:15:51 UTC
After checking more carefully, this is a duplicate of #97337.  The temporary fix
seems to work for now.  Closing as a duplicate.

*** This bug has been marked as a duplicate of 97337 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.