Bug 106037 - changing owner/group of a file
Summary: changing owner/group of a file
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-02 07:23 UTC by louisgtwo
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 09:08:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of problem (481.78 KB, image/png)
2003-10-09 05:27 UTC, louisgtwo
no flags Details

Description louisgtwo 2003-10-02 07:23:39 UTC
when changing the owner or group of a file (from root) the drop down menus are
not saturated with the options especially when the nautilus window is close to
the edge of the desktop. I believe this was fixed in the latest versions of the
2.2 series.

Comment 1 Mike A. Harris 2003-10-06 15:58:53 UTC
Perhaps "populated" is the word you were looking for instead of saturated?
Just a guess as "saturated" doesn't make much sense in this context...


http://dictionary.reference.com/search?q=saturated

sat·u·rate   Audio pronunciation of saturated ( P )  Pronunciation Key  (sch-rt)
tr.v. sat·u·rat·ed, sat·u·rat·ing, sat·u·rates

   1. To imbue or impregnate thoroughly: âThe recollection was saturated with
sunshineâ (Vladimir Nabokov). See Synonyms at charge.
   2. To soak, fill, or load to capacity.
   3. Chemistry. To cause (a substance) to unite with the greatest possible
amount of another substance.



Comment 2 Alexander Larsson 2003-10-06 16:05:43 UTC
I'm not sure what you mean here. Can you describe the problem you're having a
bit more?

With nautilus you can't currently change the owner of a file, and you can't
change the group to a group you're not a member of.


Comment 3 louisgtwo 2003-10-06 22:56:16 UTC
When looking at permissions for a file if the properties windows is at the top
or bottom of the desktop the owner and group drop down menus are not populated
fully.

Comment 4 louisgtwo 2003-10-06 22:59:09 UTC
You gave to be loggon on as root. I know this is a no-no but a necessity.

Comment 5 Alexander Larsson 2003-10-07 10:09:46 UTC
It works well for me. You have to scroll the menu of course, like with any gtk+
menu that doesn't fit on the screen.


Comment 6 louisgtwo 2003-10-08 01:43:23 UTC
No, when the menu pops up it is not populated fully. Their is a large blank
space at the bottom of menu. This is when the properties window is at the top of
the desktop.

Comment 7 Alexander Larsson 2003-10-08 10:05:59 UTC
That happens for me to, then there is an arrow on the top which lets you scroll
the menu to reach the other menu items. This is working as designed for me. If
you don't get the scroll button at the top of the menu, please post a screenshot
of how the menu looks for you.

Comment 8 louisgtwo 2003-10-09 05:27:53 UTC
Created attachment 95050 [details]
screenshot of problem

As you can see the pop up menu is not fully populated. This looks unpolished to
me.

Comment 9 Alexander Larsson 2003-10-09 09:08:06 UTC
It looks exactly like it should, and how i described. If you want to get the
rest of the items you have to scroll the menu. The reason it is like this is
that if you pop up the menu the currently selected item has to be over the
pop-up spot, since otherwise its easy to accidentally change to something else.
This is core gtk+ behaviour.



Note You need to log in before you can comment on or make changes to this bug.