Bug 106043 - strace -fF hangs on simple pthread program
Summary: strace -fF hangs on simple pthread program
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: strace (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-02 08:40 UTC by Dmitry V. Levin
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-14 23:40:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stracetest.c (273 bytes, text/x-csrc)
2003-10-02 08:40 UTC, Dmitry V. Levin
no flags Details
patch which fix the problem (43 bytes, patch)
2003-12-14 23:37 UTC, Dmitry V. Levin
no flags Details | Diff

Description Dmitry V. Levin 2003-10-02 08:40:17 UTC
Description of problem: 
This trivial "badly written" pthread test causes "strace -fF" to hang. 
 
Version-Release number of selected component (if applicable): 
Tested strace-4.4.99 and strace-4.4 
 
How reproducible: 
Always on all (available for me) linuxthreads platforms. 
 
Steps to Reproduce: 
gcc -Wall -Werror stracetest.c -lpthread -o stracetest 
strace -fF ./stracetest

Comment 1 Dmitry V. Levin 2003-10-02 08:40:57 UTC
Created attachment 94874 [details]
stracetest.c

Comment 2 Roland McGrath 2003-11-07 02:13:37 UTC
I cannot reproduce this in 4.4.99-1.  Please verify the strace, glibc,
and kernel versions you are using.

Comment 3 Dmitry V. Levin 2003-11-07 13:24:28 UTC
As I wrote in original post before bugzilla corruption, 
tested with 
kernel-2.2.25 and kernel-2.4.22, 
glibc-2.2.5 and glibc-2.3.2, 
on few ALT Linux and Debian distributions. 
All above with linuxthreads. 

Comment 4 Dmitry V. Levin 2003-12-14 23:37:20 UTC
Created attachment 96533 [details]
patch which fix the problem

Comment 5 Dmitry V. Levin 2003-12-14 23:40:57 UTC
Apparently fixed in strace-4.5.1 (linuxthreads bug?); 
your patch which fixes the problem is attached for convenience. 


Note You need to log in before you can comment on or make changes to this bug.