Bug 106057 - dbenv->close() happens in wrong directory when doing chroot-installs
dbenv->close() happens in wrong directory when doing chroot-installs
Status: CLOSED DUPLICATE of bug 103852
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-02 08:39 EDT by Enrico Scholz
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-05 07:12:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2003-10-02 08:39:17 EDT
Description of problem:

1. mkdir -p /tmp/foo/x
2. rpm -r /tmp/foo --dbpath /x -U setup-2.5.26-1.noarch.rpm
   | rpmdb: /x/Triggername: No such file or directory
   | rpmdb: /x/Triggername: cannot sync: No such file or directory
   | error: db4 error(2) from dbenv->close: No such file or directory

strace shows e.g.

| 17360 rename("/x/__db.Triggername.", "/x/Triggername") = 0
| 17360 open("/x/Triggername", O_RDWR|O_LARGEFILE) = 19
| ...
| 17360 chroot(".")                       = 0
| ...
| 17360 open("/x/Triggername", O_RDWR|O_LARGEFILE) = -1 ENOENT (No such file or
directory)


Version-Release number of selected component (if applicable):

rpm-4.2.1-0.30
Comment 1 Paul Nasrat 2005-11-29 10:58:13 EST
This is fixed in upstream rpm, I'm hoping to backport for FC5t2.
Comment 2 Jeff Johnson 2006-08-05 07:12:26 EDT

*** This bug has been marked as a duplicate of 103852 ***

Note You need to log in before you can comment on or make changes to this bug.