Bug 106114 - Internal compiler error in extract_insn, at recog.c:2149
Internal compiler error in extract_insn, at recog.c:2149
Status: CLOSED DUPLICATE of bug 106113
Product: Red Hat Linux Beta
Classification: Retired
Component: gcc32 (Show other bugs)
AS-beta2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-02 17:51 EDT by Tru Huynh
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tru Huynh 2003-10-02 17:51:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030708

Description of problem:
background:

Dual opteron 242, 4 GB of RAM running taroon (all updates applied
as of 2003/09/29).

[tru@calimero build]$ rpm -q gcc
gcc-3.2.3-20
[tru@calimero build]$ gcc -v
Reading specs from /usr/lib/gcc-lib/x86_64-redhat-linux/3.2.3/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-syst
em-zlib --enable-__cxa_atexit --host=x86_64-redhat-linux
Thread model: posix
gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-20)

pb:
gcc  -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -O2 -c  -I../include
-I/usr/X11R6/include -L/usr/X11R6/lib64 -DWIN_MOTIF alignmgr.c 

exits with an internal compiler error.

workaround:
install gcc-3.3.1 on the opteron and compile with it.

the default compilers on the taroon fails whereas, gcc-3.3.1
(rebuild on taroon) works, the default SuSE and Mandrake compilers
for x86_64 are working out of the box.


Version-Release number of selected component (if applicable):
gcc-3.2.3-20

How reproducible:
Always

Steps to Reproduce:
1.Dual opteron 242, 4 GB of RAM running taroon (all updates applied
as of 2003/09/29).
2. gcc  -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -O2 -c  -I../include
-I/usr/X11R6/include -L/usr/X11R6/lib64 -DWIN_MOTIF alignmgr.c 

3.
    

Actual Results:  In file included from ../include/ncbi.h:57,
                 from ../include/alignmgr.h:261,
                 from alignmgr.c:573:
../include/ncbilcl.h:104:2: warning: #warning Unknown processor type. Please
define something appropriate.
alignmgr.c: In function `AlnMgrIndexParentSA':
alignmgr.c:1586: warning: cast to pointer from integer of different size
alignmgr.c: In function `AlnMgrGetAllNForSip':
alignmgr.c:4799: unrecognizable insn:
(insn 367 374 328 (set (reg/v:SI 64)
        (plus:SI (reg:SI 97)
            (const_int 1 [0x1]))) -1 (nil)
    (expr_list:REG_DEAD (reg:SI 97)
        (nil)))
alignmgr.c:4799: Internal compiler error in extract_insn, at recog.c:2149
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.


Expected Results:  should produce the correct object.



Additional info:
Comment 1 Bill Nottingham 2003-10-02 17:51:53 EDT

*** This bug has been marked as a duplicate of 106113 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.