Bug 106124 - segfault in gtk_im_context_xim_new on x86_64 in CJK locales
segfault in gtk_im_context_xim_new on x86_64 in CJK locales
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gtk2 (Show other bugs)
3.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
: 106133 (view as bug list)
Depends On:
Blocks: 104704
  Show dependency treegraph
 
Reported: 2003-10-02 19:03 EDT by Mike McLean
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 15:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full backtrace (3.60 KB, text/plain)
2003-10-02 19:04 EDT, Mike McLean
no flags Details
full backtrace (gnome-terminal) (4.79 KB, text/plain)
2003-10-02 21:37 EDT, Mike McLean
no flags Details

  None (edit)
Description Mike McLean 2003-10-02 19:03:48 EDT
* Taroon-re0929.RC1.0 ES
* LANG=ja_JP.eucJP
gtk2-2.2.4-3.0.i386
gtk2-2.2.4-3.0.x86_64
glibc-2.3.2-95.2.i686
glibc-2.3.2-95.2.x86_64
kernel-2.4.21-3.EL.x86_64
python-2.2.3-5.x86_64
firstboot-1.1.19-1.noarch

After a japanese language install, firstboot dies as soon as it hits the
date/time configuration screen.  The debugger suggests gtk is to blame.

Will attach full backtrace.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 182894217376 (LWP 3648)]
0x0000002a9e64fbde in gtk_im_context_xim_new () from
/usr/lib64/gtk-2.0/2.2.0/immodules/im-xim.so
(gdb) bt
#0  0x0000002a9e64fbde in gtk_im_context_xim_new () from
/usr/lib64/gtk-2.0/2.2.0/immodules/im-xim.so
#1  0x0000002a96e04d30 in gtk_im_context_set_cursor_location () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x0000002a96e06bf8 in gtk_im_multicontext_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x0000002a96e04d30 in gtk_im_context_set_cursor_location () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x0000002a96de9281 in gtk_entry_get_type () from
Comment 1 Mike McLean 2003-10-02 19:04:25 EDT
Created attachment 94901 [details]
full backtrace
Comment 2 Mike McLean 2003-10-02 20:28:22 EDT
Also happens in ko_KR, zh_TW, zh_TW.Big5, and zh_CN.GB18030

For some reason it does not seem to happen with LANG=zh_CN
Comment 3 Mike McLean 2003-10-02 21:36:25 EDT
Getting something similar from with gnome-terminal:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 182894217280 (LWP 4541)]
gtk_im_context_xim_focus_in (context=0x30) at gtkimcontextxim.c:745
745           context_xim->has_focus = TRUE;
(gdb) bt
#0  gtk_im_context_xim_focus_in (context=0x30) at gtkimcontextxim.c:745
#1  0x0000002a9705db45 in gtk_im_context_focus_in (context=0x89d1a0)
    at gtkimcontext.c:337
#2  0x0000002a9705fb59 in gtk_im_multicontext_focus_in (context=0x0)
    at gtkimmulticontext.c:339
#3  0x0000002a9705db45 in gtk_im_context_focus_in (context=0x72dca0)
    at gtkimcontext.c:337
#4  0x0000002a9569abbe in vte_terminal_focus_in (widget=0x6810a0,
    event=0x8bb480) at vte.c:10002
Comment 4 Mike McLean 2003-10-02 21:37:05 EDT
Created attachment 94906 [details]
full backtrace (gnome-terminal)
Comment 5 Bill Nottingham 2003-10-03 10:34:31 EDT
On a lark, what happens if you install the XFree86-libs & other XFree86 bits
from dist-3.0E-HEAD?
Comment 6 Mike McLean 2003-10-03 12:04:38 EDT
hmm, gnome-terminal runs fine if you run it within a gnome-session, but blows up
if you try it under X+twm.
Comment 7 Mike McLean 2003-10-03 12:12:16 EDT
hmm, the firstboot bug does not appear if you run it under a gnome-session...
Comment 8 Mike McLean 2003-10-03 12:30:44 EDT
*** Bug 106133 has been marked as a duplicate of this bug. ***
Comment 9 Mike McLean 2003-10-03 12:33:12 EDT
export XMODIFIERS="@im=kinput2" gets gdm, firstboot, and gnome-terminal to run
in the ja_JP.eucJP locale.
Comment 10 Bill Nottingham 2003-10-03 15:10:47 EDT
I cannot reproduce this failure on ia64.
Comment 11 Mike McLean 2003-10-03 16:18:07 EDT
does not happen s390x
Comment 12 Mike McLean 2003-10-06 12:54:45 EDT
seems fixed in Taroon-re1004.RC1.0 (gtk2-2.2.4-4.0)
Comment 13 Owen Taylor 2003-10-06 13:02:46 EDT
Yeah, I stilil need to rebuild in Cambridge, but other than that, it should
be fixed.
Comment 14 Owen Taylor 2003-10-15 15:21:43 EDT
* Fri Oct  3 2003 Owen Taylor <otaylor@redhat.com> 2.2.4-4.0
- Fix 64-bit problem in gtkimcontextxim.c (#106124)

Note You need to log in before you can comment on or make changes to this bug.