Bug 106125 - Orphaned deleted inodes in /tmp
Orphaned deleted inodes in /tmp
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: apache (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-02 19:04 EDT by Tom Carpenter
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:24:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Carpenter 2003-10-02 19:04:20 EDT
Description of problem:
Orphaned inodes in /tmp (80k+ at a time).  Eventually causes and "out of 
space" error on /tmp forcing a reboot to clear.  

Version-Release number of selected component (if applicable):
2.1as_e25 (happens on e8 and e16 as well)

How reproducible:
unknown.  Appears to be related to builds using Apache ant v1.5.

Steps to Reproduce:
1.
2.
3.
    
Actual results:
debugfs:  ncheck 256511
Inode   Pathname
256511  <inode not found>

debugfs:  stat 256511
256511: File not found by ext2_lookup

Deleted inodes on server:
Under normal situations, deleted inodes should be zero.

wc -l /tmp/debugfs.out
  86067 /tmp/debugfs.out

Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/cciss/c0d0p7     256512   80560  175952   32% /tmp


Sample list of deleted inodes on server:
Too many to list. There are about 86,000+

debugfs:   Inode  Owner  Mode    Size    Blocks    Time deleted
  6137   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6138   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6139   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6140   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6141   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6144    783  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6145    783  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6146   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6147   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6148   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6149    783  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6150   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6151   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003
  6152   5704  40777   4096    1/   1 Fri Sep  5 15:27:49 2003


Expected results:


Additional info:
Comment 1 Joe Orton 2005-10-12 08:58:20 EDT
Is this bug still reproducible?  If the bug was due to Ant rather than the
Apache HTTP server then this is not the appropriate place to report the issue.
Comment 3 RHEL Product and Program Management 2007-10-19 15:24:01 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.