This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 106127 - jwhois.conf contains incorrect information for .edu.au
jwhois.conf contains incorrect information for .edu.au
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: jwhois (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-02 19:19 EDT by Paul Gear
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-15 11:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds .edu.au override to jwhois.conf (383 bytes, patch)
2003-10-02 19:22 EDT, Paul Gear
no flags Details | Diff

  None (edit)
Description Paul Gear 2003-10-02 19:19:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
There is no domain override for .edu.au domains in jwhois.conf, thus when a
domain in .edu.au is queried, the .au entry is used.  This actually returns
information, but it is not correct or current information, due to the fact that
.edu.au has been moved to ausregistry.net.au.  The default jwhois.conf should
include the line:


Version-Release number of selected component (if applicable):
jwhois-3.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. jwhois anything.edu.au (uq.edu.au shown in examples below)
2.
3.
    

Actual Results:  [root@penguin root]# whois uq.edu.au
[Querying whois.aunic.net]
[whois.aunic.net]

% Copyright 2001 auDA.  Terms of Use at http://www.aunic.net/copyright.html

domain:      uq.edu.au
descr:       The University of Queensland
descr:       The University of Queensland
descr:       Brisbane
descr:       QLD 4072
admin-c:     CT260-AU
tech-c:      CT260-AU
zone-c:      CT260-AU
remarks:     Created 19971208
changed:     nobody@aunic.net 19991123
source:      AUNIC

person:      Chris Teakle
address:     University of Queensland
address:     Brisbane
address:     QLD 4072
address:     AU
phone:       +61 7 3365 4400
fax-no:      +61 7 3365 7539
e-mail:      hostmaster@uq.edu.au
nic-hdl:     CT260-AU
remarks:     (Organisation) Information Technology Services
remarks:     (position) Supervising Systems Programmer
remarks:     Created 19971208
changed:     nobody@aunic.net 19991123
source:      AUNIC

Expected Results:  [root@penguin root]# whois -h whois.ausregistry.net.au uq.edu.au
[Querying whois.ausregistry.net.au]
[whois.ausregistry.net.au]
Domain Name:             uq.edu.au
Last Modified:           Never Updated
Registrar ID:            R00085-AR
Registrar Name:          EducationAU
Status:                  ok

Registrant ROID:         C1214668-AR
Registrant Contact Name: Chris Teakle
Registrant Email:        hostmaster@uq.edu.au

Tech ID:                 C1214668-AR
Tech Name:               Chris Teakle
Tech Email:              hostmaster@uq.edu.au

Name Server:             ns1.uq.edu.au
Name Server IP:          130.102.128.53
Name Server:             ns2.uq.edu.au
Name Server IP:          130.102.2.53
Name Server:             ns3.uq.edu.au
Name Server IP:          203.15.35.53
Name Server:             dns.aarnet.edu.au
Name Server IP:          192.231.212.69


Additional info:
Comment 1 Paul Gear 2003-10-02 19:22:41 EDT
Created attachment 94902 [details]
Adds .edu.au override to jwhois.conf

Is there an award for the highest percentage of trivial patches contributed? 
:-)
Comment 2 Miloslav Trmač 2004-08-15 11:29:19 EDT
There seems to be no difference now:

$ whois uq.edu.au > 1
$ whois -h whois.ausregistry.net.au uq.edu.au > 2
$ diff -u 1 2
--- 1   2004-08-15 16:28:55.760493864 +0200
+++ 2   2004-08-15 16:28:41.486663816 +0200
@@ -1,5 +1,5 @@
-[Querying whois.aunic.net]
-[whois.aunic.net]
+[Querying whois.ausregistry.net.au]
+[whois.ausregistry.net.au]
 Domain Name:             uq.edu.au
 Last Modified:           10-Jun-2004 03:36:20 UTC
 Registrar ID:            R00085-AR


I also can't find any document supporting this change at www.aunic.net.

If the override still should be added, please report it
upstream at bug-jwhois@gnu.org.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.