Bug 106236 - LTC4740-Compatibility libraries are not installed by default in WS edition
LTC4740-Compatibility libraries are not installed by default in WS edition
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: comps (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: dff
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-03 16:52 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 17:09:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-10-03 16:52:13 EDT
The following has be reported by IBM LTC:  
Compatibility libraries are not installed by default in WS edition
Hardware Environment:
Intellistation 2-way, 550Mhz, 1gb ram

Software Environment:
RedHat Enterprise Linux v3, WS edition

Steps to Reproduce:
1. Install RHEL 3, take basically the defaults (I added in some dev stuff and
selected KDE as default manager)
2.  ls -la /usr/lib/libstdc++*
3.  Note that only the one for gcc 3.2.3 is there, the compatibility ones are
missing
    Also, the libdb compat library is also not installed by default.

This may or may not be a bug, but I seem to recall in the betas that these did
get installed by default.  Maybe I'm mis-remembering.  They are present on disc
3, and after installing them I was able to get WebSphere AppServer to run (We
have native embedded products that depend on the older version of C++ and db).

Can you tell me if they are supposed to be installed by default or not?  If not,
then We'll need to document it in Websphere AppServer  for customers to be able
to correctly install and config.



Actual Results:

Expected Results:

Additional Information:Glen/Greg - please submit this issue to Red Hat.  Thanks.
Comment 1 Jeremy Katz 2003-10-03 17:09:58 EDT
No, the legacy compatibilty libraries are not intended to be installed by
default.  They should only be added to the system by customers as needed for
running applications which may have been built on older releases.
Comment 2 IBM Bug Proxy 2003-10-16 00:29:48 EDT
------ Additional Comments From khoa@us.ibm.com  2003-15-10 23:38 -------
Closing this bug.... 

Note You need to log in before you can comment on or make changes to this bug.