Bug 10624 - KickStart fails to recognize --static
Summary: KickStart fails to recognize --static
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-06 22:08 UTC by Matt Swanson
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2000-04-11 16:44:05 UTC


Attachments (Terms of Use)

Description Matt Swanson 2000-04-06 22:08:09 UTC
There was/is a similar problem w/ 6.1.
My ks.cfg has:
network --static -ip XXX.XXX.XXX.XXX ...
Last message in A-F3:
* kickstarting through device eth0
A dialog stating: 'bad argument to kickstart network command --static:
unknown option' appears, preventing my automated install from completing.

Comment 1 Jay Turner 2000-04-11 16:43:59 UTC
The problem is that you are not using the correct syntax.  The proper command
for static addressing is "network --bootproto static --ip XXX.XXX.XXX.XXX ..."

Comment 2 Daniel Roesen 2000-04-14 23:46:59 UTC
The problem is mkkickstart generating wrong "network" hint line (with
"--static"). See Bug #10622


Note You need to log in before you can comment on or make changes to this bug.