Bug 106244 - Can't locate module oprofile
Summary: Can't locate module oprofile
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-03 21:59 UTC by John Reiser
Modified: 2015-01-04 22:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 01:49:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Reiser 2003-10-03 21:59:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031002

Description of problem:
The kernel module oprofile seems to be omitted from the kernel .rpm, which means
that the oprofile applications will not run.

As root ('#' prompt from bash):
-----
# opcontrol --init
modprobe: Can't locate module oprofile
modprobe: Can't locate module oprofile
Kernel doesn't support oprofile
# /sbin/lsmod | grep oprof
#     ## empty: no oprofile module loaded
# find /lib/modules/2.4.22-1.2082.nptl -name '*oprof*'
#     ## empty: no oprofile module in .rpm
# grep OPROFILE /boot/config-2.4.22-1.2082.nptl
CONFIG_OPROFILE=m     ## inconsistent with above attempts at usage
# rpm -qa | grep oprofile
oprofile-0.7cvs-0.20030829.6
# 
-----


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2082.nptl.i686.rpm

How reproducible:
Always

Steps to Reproduce:
1. up2date install kernel-2.4.22-1.2082.nptl.i686.rpm
2. reboot
3. opcontrol --init
    

Actual Results:  modprobe: Can't locate module oprofile
modprobe: Can't locate module oprofile
Kernel doesn't support oprofile

Expected Results:  oprofile module installed and initialized.

Additional info:

Comment 1 Bill Nottingham 2003-10-04 03:35:30 UTC
It's in the SMP kernel.

Comment 2 Dave Jones 2003-10-09 01:48:57 UTC
This is due to us not enabling APIC on UP kernels.
AFAIK, this policy isn't going to change.
 


Note You need to log in before you can comment on or make changes to this bug.