Bug 10625 - installer chooses bad X config for Matrox Millennium on Alpha
Summary: installer chooses bad X config for Matrox Millennium on Alpha
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-06 22:31 UTC by Mounish Desai
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 19:39:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mounish Desai 2000-04-06 22:31:09 UTC
I have a Matrox Millennium I in a DIGITAL PersonalWorkstation 433a.  The
installer tries to run X in what appears to be 640x480.  The display has
alternating verticle bars of the correct graphic and a light blue (I
assume it's the root window color).

The Xconfigurator run by the text installer cannot probe the card.  It
incorrectly identifies the card as having 4MB of VRAM.

Xconfigurator run from the installed system can correctly probe and
generate a config file that works at 1024x768 (the default) and I also
tried it at 640x480.  It correctly identifies the card has having 2MB of
VRAM.

Comment 1 Anonymous 2000-04-11 02:43:59 UTC
The problem is that kudzu's cards database (in
instimage/usr/share/kudzu/pcitable  contains this
entry:

0x102b	0x0519	"Card:Matrox Millennium 4MB"	"Matrox|MGA 2064W [Millennium]"

change it to this:

0x102b	0x0519	"Card:Matrox Millennium 2MB"	"Matrox|MGA 2064W [Millennium]"

and things work.  Of course, this is just a hack, as
I don't know for certain that there are no 1MB Matrox Millennium cards
out there.

Comment 2 Michael Fulbright 2000-10-02 19:39:05 UTC
Probing memory on Matrox cards is not reliable yet - please manually choose the
amount of RAM your card has.


Note You need to log in before you can comment on or make changes to this bug.