Bug 106256 - htmlview should prefer GNOME or KDE browsers to X11_GENERIC
htmlview should prefer GNOME or KDE browsers to X11_GENERIC
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: htmlview (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 03:50 EDT by Behdad Esfahbod
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:13:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to cause htmlview to use browser defined by gnome-default-applications-properties (544 bytes, patch)
2004-03-15 19:26 EST, W. Michael Petullo
no flags Details | Diff

  None (edit)
Description Behdad Esfahbod 2003-10-04 03:50:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/1.0

Description of problem:
Better when htmlview detects GNOME is running, then it prefer X11BROWSERS_GNOME
to X11BROSERS_GENERIC.  Same for KDE.

BTW, better it does a better check for a GNOME session.  It completely fails in
a multi-user environment (pidof gnome-session).

Version-Release number of selected component (if applicable):
htmlview-2.0.0-10

How reproducible:
Always

Steps to Reproduce:
1. See the source.
2.
3.
    

Additional info:
Comment 1 W. Michael Petullo 2004-03-15 19:24:04 EST
Currently (2.0.0-12), htmlview will look to see if GConf's
/desktop/gnome/url-handlers/unknown is defined.  However, when one
sets their default browser using the GNOME control center's
gnome-default-applications-properties only
/desktop/gnome/url-handlers/http gets set.  One of two things should
be changed:

1.  htmlview should be patched to read
/desktop/gnome/url-handlers/http instead of
/desktop/gnome/url-handlers/unknown (see attached patch)

- or -

2.  control-center should be patched to write the user's selected
default browser to /desktop/gnome/url-handlers/unknown (and probably
https) in addition to /desktop/gnome/url-handlers/http.
Comment 2 W. Michael Petullo 2004-03-15 19:26:31 EST
Created attachment 98556 [details]
Patch to cause htmlview to use browser defined by gnome-default-applications-properties
Comment 3 W. Michael Petullo 2004-03-15 19:33:42 EST
See also http://bugzilla.gnome.org/show_bug.cgi?id=123487.
Comment 4 W. Michael Petullo 2004-05-02 20:12:50 EDT
This seems to be fixed in rawhide.  From the RPM's ChangeLog:

[...]
* Fri Apr 16 2004 Warren Togami <wtogami@redhat.com> 2.0.0-13
 
- read http instead of unknown key
[...]
Comment 5 W. Michael Petullo 2004-06-25 15:24:13 EDT
Could the submitter of this bug test the rawhide htmlview package to
see if this bug is fixed?  I think this bug should be closed (see
comment #4).

Note You need to log in before you can comment on or make changes to this bug.