Bug 106260 - Installer crashes when trying to detect existing root partitions
Installer crashes when trying to detect existing root partitions
Status: CLOSED DUPLICATE of bug 99384
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 06:43 EDT by Henrik Nielsen
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Nielsen 2003-10-04 06:43:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Description of problem:
After choosing language, keyboard and mouse, installer apparently tries to start
partioning tool and promptly crashes with following spew:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 761, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 42, in findRootParts
    id.rootParts = findExistingRoots(intf, id, chroot)
  File "/usr/lib/anaconda/upgrade.py", line 65, in findExistingRoots
    rootparts = diskset.findExistingRootPartitions(intf, chroot)
  File "/usr/lib/anaconda/partedUtils.py", line 479, in findExistingRootPartitions
    lvm.vgactivate()
  File "/usr/lib/anaconda/lvm.py", line 81, in vgactivate
    raise SystemError, "vgchange failed"
SystemError: vgchange failed

My disk setup consists of:
hda: 120GB Maxtor disk containing Windows install, multimedia files and games
hdb: 40GB IBM disk - intended target for Redhat 9 install

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put in cd1 and reboot - doesn't matter if text only install is chosen
2. Choose language, keyboard and mouse
3. Stare annoyed at crash message :)
    

Actual Results:  Installer crashes, outputting listed error message.

Expected Results:  Installer should have continued to disk editing part I suppose...

Additional info:

See above in description for relevant error message and my disk setup.
Comment 1 Michael Fulbright 2003-10-09 12:24:41 EDT
The patch in bug 102193 may be of help.
Comment 2 Brent Fox 2004-04-16 17:01:35 EDT

*** This bug has been marked as a duplicate of 99384 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:58:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.