Bug 106272 - Tab mode + workspaces doesn't work well (feature regression)
Tab mode + workspaces doesn't work well (feature regression)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: galeon (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 12:55 EDT by Toralf
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 13:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-10-04 12:55:23 EDT
Description of problem:
In Red Hat 7.3, with galeon set up to open new tabs instead of windows, it would
still open a new window if the current one(s) belonged to a different workspace
(when issuing 'galeon' on the command line, using GNOME URL open function etc.),
so that you'd end up with one window per workspace.

In Red Hat 9, this functionality is gone. Galeon will always add a tabs to the
same window, which is very confusing when it belongs to a different workspace,
as it looks like the URL open operation did nothing.

What the correct behaviour is, is debatable, but the current one is defintely
wrong. Galeon should either open one window per workspace as it did in the past,
move the window to the current workspace when another tab was inserted, or make
its window sticky.

Version-Release number of selected component (if applicable):
1.2.7-3


How reproducible:
Every time

Steps to Reproduce:
1. Set up galeon to open new tabs instead of new window
2. Start galeon (click launcher or issue 'galeon' on the command line.)
3. Repeat
4. Switch to a different workspace
5. Issue 'galeon' again
    
Actual results:
2: Galeon window opened.
3: New tab added to the same window.
5: 3rd tab added to orignal window, which you won't see, becuase it's on a
different workspace

Expected results:
2: Galeon window opened.
3: New tab added to the same window.
5: Another galeon window opened for the current workspace
   - or -
   3rd tab added to orignal window, and window made visible on current workspace.
Comment 1 Christopher Blizzard 2003-10-09 13:26:26 EDT
We aren't even shipping galeon right now, and I'm not going to go back to RH 9
to fix this.  I would suggest reporting this upstream to the galeon maintainers
to try to get it fixed.

Note You need to log in before you can comment on or make changes to this bug.