Bug 106295 - Installer did not setup sound
Installer did not setup sound
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 106322 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 02:19 EDT by Ted Kaczmarek
Modified: 2015-01-04 17:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-19 18:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2003-10-05 02:19:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/1.0

Description of problem:
Sound not setup during install, play test sound failed, unable to load module i810.

Version-Release number of selected component (if applicable):
anaonda-9.0.94-0.2003022192145

How reproducible:
Didn't try

Steps to Reproduce:
1.Update beta .93 to Fedora on Sager NP4760
2.Reboot
3.Play Sound fails
    

Actual Results:  Fails to setup sound on install

Expected Results:  Sound is setup on install.

Additional info:

This worked fine on the .93 version of the beta, modprobe i810 is ok, but the
redhat-config-sound gripes about i810_audio. Dmesg states i810_audio unable to
allocate irq 0. Please refer to appropriate pkg, I parked it here because it
happened during install.
Comment 1 Ted Kaczmarek 2003-10-05 02:49:25 EDT
Tried latest rawhide kernel, passed pci=biosirq for option, 
i810: SiS 7012 found at IO 0x1800 and 0x1c00, MEM 0x0000 and 0x0000, IRQ 0
i810_audio: unable to allocate irq 0.
lspci 
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound
Controller (rev a0)

Will try same kernel I had with 0.93.
Comment 2 Ted Kaczmarek 2003-10-05 03:04:03 EDT
Sound works like a charm with 2.4.21-20.1.2024.2.1.nptl kernel. 
Did not work with 
kernel-2.4.22-1.2061.nptl
kernel-2.4.22-1.2086.nptl

Guess we need to reassign this to kernel guys. Please reassign.
Thanks,
Ted
Comment 3 Ted Kaczmarek 2003-10-05 12:30:21 EDT
*** Bug 106322 has been marked as a duplicate of this bug. ***
Comment 4 Ted Kaczmarek 2003-10-14 18:09:09 EDT
2.4.22-1.2088.nptl on same Laptop, i686.
Dmesg below.
Intel 810 + AC97 Audio, version 0.24, 20:27:06 Oct  9 2003
PCI: No IRQ known for interrupt pin C of device 00:02.7. Please try using
pci=biosirq.
i810: SiS 7012 found at IO 0x1800 and 0x1c00, MEM 0x0000 and 0x0000, IRQ 0
i810_audio: unable to allocate irq 0
Intel 810 + AC97 Audio, version 0.24, 20:27:06 Oct  9 2003
PCI: No IRQ known for interrupt pin C of device 00:02.7. Please try using
pci=biosirq.
i810: SiS 7012 found at IO 0x1800 and 0x1c00, MEM 0x0000 and 0x0000, IRQ 0
i810_audio: unable to allocate irq 0

If you know where I can get kernel-source for 2.4.21-20.1.2024.2.1.nptl it would
be greatly appreciated.

Thanks,
Ted
Comment 5 Dave Jones 2003-10-16 11:35:22 EDT
Does it work if you boot with acpi=on ?
Comment 6 Ted Kaczmarek 2003-10-19 18:28:34 EDT
Yes it does :-) Tried it with 2.4.22-1.2088.nptl and 2.4.22-1.2097.nptl, thanks
a bunch. Does this allow for some pci to irq mapping that falls under advanced
configuration? Also you guys have done a fantastic job on Fedora, very impressive
with no real major glitches to speak off. And I am using a brand spanking new
laptop. Hats off to Redhat.

This would fall under notabug I assume , hehe. Pebkac error.
Ted

Note You need to log in before you can comment on or make changes to this bug.