This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 106301 - ppp bad source code
ppp bad source code
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
: 111080 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 05:02 EDT by d.binderman
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 06:59:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-10-05 05:02:58 EDT
Description of problem:

Hello there,

I have just tried to compile package ppp-2.4.1-10, from Redhat 9.0,
with compiler flag -Wall.

The compiler said

pppdump.c:166: warning: too few arguments for format
pppdump.c:395: warning: too few arguments for format
pppdump.c:421: warning: `return' with no value, in function returning non-void
pppdump.c:424: warning: `return' with no value, in function returning non-void


Looks like something worth fixing.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Woerner 2004-06-21 06:41:12 EDT
*** Bug 111080 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Woerner 2004-06-21 06:59:20 EDT
Fixed in rawhide in rpm ppp-2.4.2-3.1 or newer.

Note You need to log in before you can comment on or make changes to this bug.