Bug 106302 - pump bad source code
Summary: pump bad source code
Status: CLOSED DUPLICATE of bug 111081
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-05 09:06 UTC by d.binderman
Modified: 2007-04-18 16:58 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 18:58:56 UTC


Attachments (Terms of Use)

Description d.binderman 2003-10-05 09:06:30 UTC
Description of problem:

Hello there,

I just tried to compile package pump-0.8.14-2, from Redhat 9.0,
with compiler flag -Wall.

The compiler said

dhcp.c:708: warning: operation on `vndptr' may be undefined
dhcp.c:708: warning: operation on `vndptr' may be undefined
dhcp.c:708: warning: operation on `vndptr' may be undefined

The source code is

    sprintf (vendor, "0x%02x 0x%02x 0x%02x 0x%02x", *vndptr++, *vndptr++, *vndptr++, *vndptr++);

Well worth fixing.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Brent Fox 2004-02-19 23:41:23 UTC

*** This bug has been marked as a duplicate of 111081 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.