Bug 106304 - ruby bad source code
ruby bad source code
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ruby (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 05:14 EDT by d.binderman
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-06 04:23:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-10-05 05:14:31 EDT
Description of problem:


Hello there,

I just tried to compile package ruby-1.6.8-5, from Redhat 9.0,
with compiler flag -Wall.

The compiler said

ruby.c:912: warning: operation on `s' may be undefined

The source code is

                s += strlen(++s);       /* this one is ok too */

You probably meant to say

                ++s;
                s += strlen(s);       /* this one is ok too */


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Akira TAGOH 2003-10-06 04:23:34 EDT
I haven't seen such warning since we used 1.8.0 in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.