Bug 106311 - vte bad source code
vte bad source code
Status: CLOSED DUPLICATE of bug 111431
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 05:40 EDT by d.binderman
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-10-05 05:40:30 EDT
Description of problem:


Hello there,

I just tried to compile package vte-0.10.25-1, from Redhat 9.0,
with compiler flag -Wall.

The compiler said

ssfe.c:756: warning: operation on `tmp' may be undefined
ssfe.c:852: warning: operation on `tmp' may be undefined
ssfe.c:864: warning: operation on `tmp' may be undefined

The source code is

        *(tmp+1)=(*tmp--);

Better source code is

        tmp[ 1] = tmp[ 0];
		--tmp;

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2004-02-07 11:56:10 EST

*** This bug has been marked as a duplicate of 111431 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.