Bug 106312 - x3270 bad source code
x3270 bad source code
Status: CLOSED DUPLICATE of bug 78479
Product: Red Hat Linux
Classification: Retired
Component: x3270 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 05:43 EDT by d.binderman
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-10-05 05:43:02 EDT
Description of problem:

Hello there,

I just tried to compile package x3270-3.2.19-4, from Redhat 9.0,
with compiler flag -Wall.

The compiler said

ft_dft.c:422: warning: operation on `obptr' may be undefined
ft_dft.c:422: warning: operation on `obptr' may be undefined
ft_dft.c:422: warning: operation on `obptr' may be undefined
ft_dft.c:422: warning: operation on `obptr' may be undefined

The source code is

                SET16(obptr, bufptr-obptr+4);

It is unwise to have obptr before the comma and after it.
Try using a temporary variable.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2004-02-06 13:35:36 EST

*** This bug has been marked as a duplicate of 78479 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.