Bug 106315 - bad source code
Summary: bad source code
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zebra   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-05 09:50 UTC by d.binderman
Modified: 2014-08-31 23:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-30 15:29:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-10-05 09:50:59 UTC
Description of problem:

Hello there,

I just tried to compile package zebra-0.93b-1, from Redhat 9.0,
with compiler flag -Wall.

The compiler said

ospf6_route.c:669: warning: operation on `p' may be undefined
ospf6_route.c:681: warning: operation on `p' may be undefined

The source code is

                  snprintf (p++, line + sizeof (line) - p, " ");

This looks like someone is assuming left to right evaluation order.
This code needs rework.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Jay Fenlason 2004-06-30 15:29:31 UTC
This has been fixed in quagga, which replaced zebra in Fedora Core.


Note You need to log in before you can comment on or make changes to this bug.