Bug 106375 - cannot see SMB shares in confir-printer-gui selection window
cannot see SMB shares in confir-printer-gui selection window
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
9
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-06 11:57 EDT by Pekka Kurki
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-06 12:06:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Kurki 2003-10-06 11:57:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0 (THIS IS NOT THE MACHINE WITH THE PROBLEM!!!!)

Description of problem:
After having problems with SMB printing (printing files from Linux to a W2000
printer) just installed redhat-config-printer-0.6.47.11-1.i386.rpm  and
redhat-config-printer-gui-0.6.47.11-1.i386.rpm  but I keep on having the same
problem in SMB printing:

- I can print a text file with samba client w/o problems
- I cannot see the share on config-printer-gui's selection list - I only see the
network names of the servers but when I click the "expansion sign" next to the
server name  no share names appear
- trying to use the "manual include" window brings no result - after having
filled in the correct 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start config-printer
2.go to selection for SMB printers
3.hit the expnansion symbol next to the server name
    

Actual Results:  no share name, nothing

Expected Results:  share name - tried to connect to 2 Win2000 machines

Additional info:
Comment 1 Tim Waugh 2003-11-05 11:05:36 EST
Fixed component.
Comment 2 Tim Waugh 2003-11-05 11:19:10 EST
Please attach the output of 'printconf-tui --Xexport', after replacing
any sensitive passwords it contains.
Comment 3 Pekka Kurki 2003-11-05 11:53:20 EST
here printconf-tui --Xexport output:

<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        </print_queues>
      </printconf>
    </datatree>
  </adm_context>

and here the same output from a machine where I had already configured
the printers in RH 7.1 and then upgradede to RH9. Here the printer
configs can be edited but no test page can be printed. (It worked in
RH7.1, no changes in other parts of the systems.)

<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1068049974">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        <hp ATOMIC="TRUE" TYPE="LIST">
          <queue_type TYPE="STRING" VALUE="SMB"/>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_data TYPE="LIST">
            <smb_share TYPE="STRING" VALUE="//kakskerta/hpoffice"/>
            <smb_ip TYPE="STRING" VALUE="192.168.0.5"/>
            <smb_workgroup TYPE="STRING" VALUE="Arbeitsgruppe"/>
            <smb_user TYPE="STRING" VALUE="usr"/>
            <smb_password TYPE="STRING" VALUE="pwd"/>
            <smb_translate TYPE="BOOL" VALUE="FALSE"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <print_header_page TYPE="BOOL" VALUE="FALSE"/>
            <flags TYPE="LIST">
              <send_FF TYPE="BOOL" VALUE="FALSE"/>
              <convert_text_to_Postscript TYPE="BOOL" VALUE="TRUE"/>
              <rerender_Postscript TYPE="BOOL" VALUE="FALSE"/>
              <assume_data_is_text TYPE="BOOL" VALUE="FALSE"/>
              <send_EOT TYPE="BOOL" VALUE="FALSE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="136928"/>
            <gs_driver TYPE="STRING" VALUE="hpijs"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              <option_default TYPE="LIST">
                <name TYPE="STRING" VALUE="PageSize"/>
                <type TYPE="STRING" VALUE="enum"/>
                <default TYPE="STRING" VALUE="A4"/>
                </option_default>
              </foomatic_defaults>
            </filter_data>
          <queue_description TYPE="STRING" VALUE="hp officejet"/>
          <jobsheets TYPE="LIST">
            <start TYPE="STRING" VALUE="none"/>
            <end TYPE="STRING" VALUE="none"/>
            </jobsheets>
          <margins TYPE="LIST">
            <top TYPE="INT" VALUE="36"/>
            <right TYPE="INT" VALUE="36"/>
            <bottom TYPE="INT" VALUE="36"/>
            <left TYPE="INT" VALUE="36"/>
            </margins>
          <lpoptions TYPE="LIST">
            </lpoptions>
          </hp>
        <hplaser ATOMIC="TRUE" TYPE="LIST">
          <queue_type TYPE="STRING" VALUE="SMB"/>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_data TYPE="LIST">
            <smb_share TYPE="STRING" VALUE="//archi/hplaser"/>
            <smb_ip TYPE="STRING" VALUE="192.168.0.6"/>
            <smb_workgroup TYPE="STRING" VALUE="WORKGROUP"/>
            <smb_user TYPE="STRING" VALUE="usr"/>
            <smb_password TYPE="STRING" VALUE="pwd"/>
            <smb_translate TYPE="BOOL" VALUE="TRUE"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <flags TYPE="LIST">
              </flags>
            <printer_id TYPE="STRING" VALUE="22976"/>
            <gs_driver TYPE="STRING" VALUE="laserjet"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              <option_default TYPE="LIST">
                <name TYPE="STRING" VALUE="PageSize"/>
                <type TYPE="STRING" VALUE="enum"/>
                <default TYPE="STRING" VALUE="A4"/>
                </option_default>
              </foomatic_defaults>
            </filter_data>
          </hplaser>
        </print_queues>
      </printconf>
    </datatree>
  </adm_context>

Comment 4 Tim Waugh 2003-11-05 11:57:14 EST
Okay, let's take this queue:

//archi/hplaser (WORKGROUP), 192.168.0.6, usr/pwd

Please show me what this command says:

smbclient -L archi
Comment 5 Pekka Kurki 2003-11-05 12:52:17 EST
archi has currently no user that I could use but I can do the same
with "kakskerta" - the major printer host. Here:

root@turku pekka]# smbclient -L kakskerta
Password:

        Sharename      Type      Comment
        ---------      ----      -------
        IPC$           IPC       Remote-IPC
        print$         Disk      Druckertreiber
        RVSFax         Printer   RVS Fax
        hpoffice       Printer   hp officejet v series
        D              Disk
        Download       Disk
        MP3            Disk
        temp           Disk
        ADMIN$         Disk      Remoteadmin
        C$             Disk      Standardfreigabe

        Server               Comment
        ---------            -------

        Workgroup            Master
        ---------            -------
[root@turku pekka]#
Comment 6 Tim Waugh 2003-11-05 12:55:03 EST
Okay, pick one of those printers and verify that redhat-config-printer
displays the problem you reported when you try to use it. (Which one
have you chosen?)
Comment 7 Pekka Kurki 2003-11-05 13:06:23 EST
OK, on this machine TURKU (with no pre-configured printers from old
version) I only see the machines kakskerta and archi but no printers
to pick (I would like to use "hpoffice" on kakskerta).
Comment 8 Pekka Kurki 2003-11-06 08:17:48 EST
to summarize the situation: I have two machines upgarades fom RH7.1 to
RH9:
- TURKU that never had printer queues before
- NAANTALI that had queues for shares //kakskerta/hpoffice and
//archi/hplaser

- on both TURKU and NAANTALI I can print to the (Win2000) shares with
smbclient
- on TURKU I cannot add new printer queues via redhat-printconf-gui -
I just see the computer names kakskerta and and archi but no printer
name expansion
- on NAANTALI I see the earlier configured queues but I cannot send
any test page
- when checking that print job with lpq I see three attempts ans then
"too many errors" on lpq result output but I cannot find any errors in
logs at /var/log/messages or in files of /var/spool/lpd/hp directrory
(hp is the queue name)
- when I try to print with lpr  -Php I also have the same result with
3 attempts.
Comment 9 Tim Waugh 2003-11-06 08:22:38 EST
> - on both TURKU and NAANTALI I can print to the (Win2000) shares
with smbclient

Please show me the syntax you use for this, so that I can compare it
to what redhat-config-printer directs CUPS to use.  Thanks.
Comment 10 Pekka Kurki 2003-11-06 09:10:47 EST
Here you are:

[root@naantali pekka]# smbclient //kakskerta/hpoffice
Password:
smb: \> print /tmp/tmp.txt
smb: \>

BTW I am not using CUPS printing but PRINTCAP. I can change this if
necessary (how?) but I haven't seen any benefit of CUPS since I have
no local printers on RedHat machines.
Comment 11 Tim Waugh 2003-11-06 10:38:40 EST
So there is no user name or password necessary? (Just clarifying)
Comment 12 Pekka Kurki 2003-11-06 10:57:13 EST
well, I was using the default user name - and the password was
necessary but not displayed on screen - of course... The result is the
same with smbclient -U option and user name. That user was also typed
in in the printconf window for setting up the printer.
Comment 13 Tim Waugh 2003-11-06 11:00:23 EST
So this works then?:

smbclient //kakskerta/hpoffice mypassword -U myuser -N -c quit

No error messages?
Comment 14 Pekka Kurki 2003-11-06 11:10:58 EST
well, for that command:

root@naantali hp]# smbclient //kakskerta/hpoffice xxxxx -U yyyyy -N -c
quit
Anonymous login successful
tree connect failed: NT_STATUS_ACCESS_DENIED
[root@naantali hp]#

on the other hand:

[root@naantali hp]# smbclient //kakskerta/hpoffice xxxxx -U yyyyy -c quit
[root@naantali hp]#

according to man that -N should only supress pwd query... - I am
confused...
Comment 15 Tim Waugh 2003-11-06 11:58:19 EST
What version of samba do you have?
Comment 16 Pekka Kurki 2003-11-06 12:02:31 EST
now samba 3.0.0 - originally I tried out some 2.x version that was on
RH9 distribution but after I had this problem I updated to 3.0.0

3.0.0 is working otherwise OK, e.g. file access with smbmount or just
by Nautilus. 
Comment 17 Tim Waugh 2003-11-06 12:06:30 EST
Okay, there are known incompatibilities with samba 3 and
redhat-config-printer in Red Hat Linux 9, and this is one of them. 
They are fixed in Fedora Core 1.

Note You need to log in before you can comment on or make changes to this bug.