Bug 106392 - (IT_34102) kernel option to allow for support of multiple LUNs at single SCSI
kernel option to allow for support of multiple LUNs at single SCSI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks: 116726 116727
  Show dependency treegraph
 
Reported: 2003-10-06 14:08 EDT by Ingolf Salm
Modified: 2007-11-30 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingolf Salm 2003-10-06 14:08:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
This kernel option is required in storage area network context. Red Hat 
provided alternate solution. However, we need to follow up for upstream kernel.
Please contact Bob Johnson formore information.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.n/a
2.
3.
    

Additional info:
Comment 1 Arjan van de Ven 2003-10-06 14:10:29 EDT
we asked IBM several times already for the contents of the /proc/scsi/scsi file
so that the relevant storage arrays can be added to the automatic whitelist, at
which point no manual option is needed. Can we *please* get that information ?
Comment 2 Ernie Petrides 2004-04-08 16:21:54 EDT
Could the bug reporter please provide contents of /proc/scsi/scsi?

Thanks.  -ernie
Comment 3 Martin Peschke 2004-04-15 09:46:48 EDT
*** Bug 115345 has been marked as a duplicate of this bug. ***
Comment 4 Martin Peschke 2004-04-15 09:48:17 EDT
Requested data or patch respectively can be found in bug 115345, which
is a duplicate of this bug.
Comment 6 Don Howard 2004-04-16 14:27:17 EDT
Date: Fri, 16 Apr 2004 20:21:52 +0200 
From: Martin Peschke3 <MPESCHKE@de.ibm.com> 
To: Don Howard <dhoward@redhat.com> 
Cc: Glen Johnson <gjlynx@us.ibm.com>, David C Fosmire 
<fosmire@us.ibm.com> 
Subject: Re: Sparse LUN support for IBM ESS 
 
 
 
 
 
It is not necessary to list various 2105 models separately. I 
suggest to add just one entry for all 2105 models along this line: 
+        {"IBM", "2105", "*", BLIST_SPARSELUN}, 
All these boxes show the same characteristics with regrad to a 
sparse 64 bit LUN address space. I have discussed this with a 
colleague in the Tucson lab, where that box comes from. Besides, 
there is an F10 model as well, to my knowledge. 
 
I first thought that the BLIST_LARGELUN and BLIST_FORCELUN flags 
would be needed in addition. But one is deprecated and the other 
should not be required since all 2105 models identify themselves as 
SCSI-3 devices. 
 
Mit freundlichen Gr�n / with kind regards 
 
Martin Peschke 
 
IBM Deutschland Entwicklung GmbH 
Linux for zSeries Development 
Phone: +49-(0)7031-16-2349 
 
 
Don Howard <dhoward@redhat.com> on 16.04.2004 19:17:26 
 
To:    Martin Peschke3/Germany/IBM@IBMDE 
cc:    Glen Johnson <gjlynx@us.ibm.com> 
Subject:    Re: Sparse LUN support for IBM ESS 
 
 
 
I haven't seen any comment from Glen regarding your patch, so here 
are his proposed patches: 
 
 
--- linux-2.4.21-9.EL/drivers/scsi/scsi_scan.c         2004-01-09 
03:22:54.000000000 +0530 
+++ linux-2.4.21-9.EL.patched/drivers/scsi/scsi_scan.c 
2004-01-27 
20:36:15.000000000 +0530 
@@ -209,6 +209,9 @@ 
             {"CNSi", "JSS122", "*", BLIST_SPARSELUN}, 
 // 
Chaparral SR0812 SR1422 
             {"CNSi", "JSS224", "*", BLIST_SPARSELUN}, 
 // 
Chaparral FR1422 
             {"NEC","iStorage","*", BLIST_SPARSELUN | BLIST_LARGELUN 
| 
BLIST_FORCELUN}, // NEC iStorage 
+        {"IBM", "2105800", "*", BLIST_SPARSELUN}, 
+        {"IBM", "2105F20", "*", BLIST_SPARSELUN}, 
+        {"IBM", "2145", "*", BLIST_SPARSELUN}, 
 
             /* 
              * Must be at end of list... 
 
 
[The 2.4.9 version is similar] 
 
 
Are the 2105x models listed in his patch different from the 2105 
that your patch addresses? 
 
Have the two of you been in contact about this issue?  From Glen's 
posts to the IT ticket, it would appear not. 
 
 
 
Comment 9 Martin Peschke 2004-05-18 07:39:22 EDT
Any 2105 model has got a sparse LUN space. This should give enough
reason for including this line:
+        {"IBM", "2105", "*", BLIST_SPARSELUN},

If this also applies to 2145, which I am not the right person to
answer, then another line for this box should be added.
Comment 10 Ernie Petrides 2004-06-10 03:53:31 EDT
Doug Ledford's patch adding SCSI whitelist entries for IBM
2105/2145 devices has just been committed to the RHEL3 U3
patch pool this evening (in kernel version 2.4.21-15.9.EL).
Comment 11 Jay Turner 2004-08-17 08:56:26 EDT
Would really like to get confirmation from IBM that the patch which
landed in the U3 kernel does indeed address the problem, as it's
different from the patch which Glen submitted and indicated had
received testing.
Comment 12 Bob Johnson 2004-08-19 14:22:26 EDT
Ingolf/Bill - Feedback on the re0813 ISO set ?
Comment 13 John Flanagan 2004-09-02 00:30:52 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.