Bug 106410 - category assignment UI half-broken
category assignment UI half-broken
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vadim Nasardinov
Jon Orris
:
Depends On:
Blocks: 106481 109665
  Show dependency treegraph
 
Reported: 2003-10-06 17:32 EDT by Vadim Nasardinov
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-04 17:38:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
category assignment UI *before* the task is locked (46.13 KB, image/png)
2003-10-06 17:33 EDT, Vadim Nasardinov
no flags Details
category assignment UI *after* the task is locked (44.02 KB, image/png)
2003-10-06 17:34 EDT, Vadim Nasardinov
no flags Details
New screen (25.07 KB, text/plain)
2003-12-03 16:50 EST, Jon Orris
no flags Details
looks fine in my mozilla at //cms/dev/...@38548 (26.15 KB, image/png)
2003-12-03 17:17 EST, Vadim Nasardinov
no flags Details

  None (edit)
Description Vadim Nasardinov 2003-10-06 17:32:23 EDT
If you go to the "Assign categories" step of the authoring kit for
Articles or some such, the UI appears slightly broken, until/unless
you lock the authoring task first.

The first screenshot shows what the UI looks like *before* the
task is locked.  The UI displays both the HTML select list widget
and what appears to be the JavaScript-based category tree widget
side by side, except the JavaScript-widget is not populated.

The second screenshot shows what the UI looks like when the
task is locked.  The HTML select list is gone, and the JavaScript-based
widget is displayed properly.
Comment 1 Vadim Nasardinov 2003-10-06 17:33:09 EDT
Created attachment 94961 [details]
category assignment UI *before* the task is locked
Comment 2 Vadim Nasardinov 2003-10-06 17:34:07 EDT
Created attachment 94962 [details]
category assignment UI *after* the task is locked
Comment 3 Vadim Nasardinov 2003-11-24 12:14:42 EST
This is also broken in 6.0 in the same way that it is broken on the
trunk.   See also bug 106406.
Comment 4 Vadim Nasardinov 2003-12-03 12:46:04 EST
Fixed in change 38458.
Comment 5 Jon Orris 2003-12-03 16:50:37 EST
Created attachment 96323 [details]
New screen

This doesn't seem much different from the original.
Comment 6 Vadim Nasardinov 2003-12-03 17:17:49 EST
Created attachment 96324 [details]
looks fine in my mozilla at //cms/dev/...@38548

Hmm.  Two comments:

 1) it does look different.  Compare to attachment 94961 [details].
    Your screenshot has the second multi-select widget,
    while 94961 does not.

 2) I can't reproduce your screenshot in my mozilla.  (BTW, you may
    want to explicitly select the mime type next time.	Bugzilla
    serves your screenshot as "text/plain", which isn't very conducive
    to correct graphic display.)  Anyhow, I'm running
       $ rpm -q mozilla
       mozilla-1.0.2-2.8.0


I'm not sure I can fix this without being able to reproduce it.  I guess
I can roll back my change and try fixing it some other way.
Comment 7 Vadim Nasardinov 2003-12-04 10:39:45 EST
Jon, can you please retest at 38492?  I made a minor HTML tweak.
Comment 8 Jon Orris 2003-12-04 17:33:42 EST
Looks ok now after I did a full clean deploy

Note You need to log in before you can comment on or make changes to this bug.