Bug 1064506 - Group Metric Graph on Dashboard empty
Summary: Group Metric Graph on Dashboard empty
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring -- Other
Version: JON 3.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER02
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 18:06 UTC by Bill DeCoste
Modified: 2018-12-06 15:52 UTC (History)
5 users (show)

(edit)
Issues with the maximizing the view of the Group Metric Graph on the Dashboard caused missing data when viewing graphs for servers in a Compatible Group, but not on individual resources. Improvements to the Group Metric Chart portlet fixes the originally-reported issue. Users can now correctly see data for servers in compatible groups.
Clone Of:
(edit)
Last Closed: 2014-12-11 14:02:27 UTC


Attachments (Terms of Use)

Comment 1 Larry O'Leary 2014-06-26 14:53:39 UTC
Re-posted:

Description of problem:

Ya, seems like a bug to me. I'll open a BZ on it.

On 2/12/14, 8:46 AM, Doug Woods wrote:
> Bill,
> Just tested, same behavior, blank on the Group Metrics, works on individual resources.
>
> However, after some probing, I clicked on the settings icon(wheel in top right of Porlet) in the Porlet Window for the Group Metrics and saw where I could assign the compatible group to assigned resources.
>
> However, when selecting the unassigned group, I could see my metric in the pull down, but after assigning the compatible group, the metrics I selected was no longer available.
>
> I could select the metric "Number of Management Requests per Minute", but obviously this is not my chosen metric to monitor at the Group level.
>
> See screen shot attached. [MISSING]
>
> -Doug
>
>
>
> ----- Original Message -----
> From: "William"
> To: "sme"
> Sent: Friday, February 7, 2014 5:50:21 PM
> Subject: Group Metric Graph on Dashboard empty
>
> Hi all,
>
> Anybody know if this is a known issue? When I create a Compatible Group
> (say 2 EAPs) and try to create a graph of the
> web/Connectors/http/anything the Group Metrc Graph pane on the dashboard
> is blank. Works fine for individual resources.
>
> Thanks -Bill



Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Spin up 2 EAP instances. Create Compatible Group containing both EAP instances recursive
2. Create a graph of the
> web/Connectors/http/anything the Group Metrc Graph pane on the dashboard
3.

Actual results:
Pane is empty


Expected results:
Pane should have a content


Additional info:

Comment 2 Jay Shaughnessy 2014-08-25 20:11:43 UTC
I coudn't recreate this completely but if I maximized/minimized the portlet the chart went away.  It came back on refresh.

We should look at that for 3.3, setting to ER02.

Comment 3 Jirka Kremser 2014-08-29 10:44:23 UTC
I can't reproduce the original issue (with metric combo-box) on ER1 neither with FF 30 nor with Chrome 36 beta. Same holds for the "Pane is empty" sub-issue. 

Minimizing and restoring the portlets works fine, but the maximizing the portlet blows away the graph for me. The pane is empty after clicking on the maximize icon. If I try to move the portlet window, the content is back again.

Comment 4 Jay Shaughnessy 2014-08-29 17:03:32 UTC
Moving to MODIFIED for ER02 as the original issue is resolved.  The maximize issue is less severe as the graph appears with a refresh.  That perhaps should be a separate BZ.

Comment 5 Simeon Pinder 2014-09-03 20:31:27 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194


Note You need to log in before you can comment on or make changes to this bug.