Bug 106506 - /usr/bin/host w/no args causes process hang
/usr/bin/host w/no args causes process hang
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.2
ia64 Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-07 17:27 EDT by Mike Alleman
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 10:54:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Alleman 2003-10-07 17:27:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

Description of problem:
Version:  bind-utils-9.2.1-1.7x.2
Synopsis: /usr/bin/host program causes process hangs if no args given to it...
Bugzilla-Product: general
Bugzilla-Component: general

Description:
I'm running RH 7.2 2.96-112.7.2 on IA-64. I usually use nslookup but decided to try
 "host" since nslookup is deprecated. Since I did not know what valid args were for
 host (besides the obvious system_name), I just typed it on the command line with
 no options. It then gave me the Usage: info, but then seemed to hang (<cr> did not
 return a prompt, nor did ctrl-c) and I could not get a system promp back. I opened 
another window and did:
# ps -efl |grep host
040 S root     19369     1  0  77   0    -   906 ia64_r 14:29 ?        00:00:00
host --version
040 S root     19370     1  0  77   0    -   906 ia64_r 14:29 ?        00:00:00
host --version
040 S root     19371     1  0  77   0    -   906 schedu 14:29 ?        00:00:00
host --version
000 S root     19491 19463  0  76   0    -   906 ia64_r 14:35 pts/3    00:00:00 host
040 S root     19493 19491  0  77   0    -   906 wait4  14:35 pts/3    00:00:00 host
040 S root     19494 19493  0  77   0    -   906 ia64_r 14:35 pts/3    00:00:00 host
040 S root     19495 19493  0  77   0    -   906 ia64_r 14:35 pts/3    00:00:00 host
040 S root     19496 19493  0  77   0    -   906 schedu 14:35 pts/3    00:00:00 host
000 S root     19498 19376  0  76   0    -   213 pipe_w 14:35 pts/0    00:00:00
grep host
--------------------------------------------------------------------------------------------
I could not kill the above processes with Sig TERM. They finally died when I
killed using sig KILL (kill -9).

This seems repeatable. Please email or call if I can help nail it down further.
version info:
#rpm -qf /usr/bin/host
bind-utils-9.2.1-1.7x.2


Version-Release number of selected component (if applicable):
bind-utils-9.2.1-1.7x.2

How reproducible:
Always

Steps to Reproduce:
1.at prompt, type /usr/bin/host <cr>
2.see usage: info
3.prompt does not come back
4. ps -efl |grep host to look for processes
    

Actual Results:  process hang, no prompt in terminal program

Expected Results:  should have a prompt if process  returned correctly

Additional info:

see description above
Comment 1 Daniel Walsh 2003-10-22 10:54:10 EDT
Not seeing that here,  Please try with latest versions of bind.

Note You need to log in before you can comment on or make changes to this bug.