Bug 106536 - HP OfficeJet G85xi USB Printing Broken: "Media Tray Empty" error
HP OfficeJet G85xi USB Printing Broken: "Media Tray Empty" error
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
http://article.gmane.org/gmane.linux....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-08 00:49 EDT by Adam Monsen
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 04:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Monsen 2003-10-08 00:49:36 EDT
Description of problem:
The HP Officejet G85xi printer is unresponsive to print requests. Setting up the
printer using 'printconf-gui' (CUPS) works as expected, setting up the printer
as a local printer seems to work fine, it even autodetects the USB printer and
figures out what kind of printer it is. However, a test page cannot be printed
("Media Tray Empty!" error), and nothing can be printed through any application.

Version-Release number of selected component (if applicable):
hpoj, cups, etc. packages bundled with Red Hat 9.

How reproducible:
Always.

Steps to Reproduce:
1. Set up local USB printer using printconf-gui
2. click 'apply' to Apply changes
3. try to print a CUPS test page
    
Actual results:
printconf-gui reports "Media Tray Empty!" errors. No useful info in
/var/log/messages or dmesg.

Expected results:
Test page would actually be printed.

Additional info:
1. This worked fine in Red Hat 8.0.
2. according to http://article.gmane.org/gmane.linux.drivers.hpofficejet.devel/651
the solution could be as simple as making sure CUPS (available at
http://localhost:631/admin) is using the 'ptal' backend and not the 'usb' backend.
3. http://article.gmane.org/gmane.linux.drivers.hpofficejet.devel/648 supplies
another possible workaround, but please no. The number of steps on this page are
insane.
Comment 1 Tim Waugh 2003-10-08 04:33:32 EDT
Yes, you must use the ptal backend, *and* you must perform the steps at
http://cyberelk.net/tim/hpoj.html.  HPOJ support does not work in current Red
Hat Linux plus updates, due to a perl bug that was never found (but went away in
a newer version).
Comment 2 Adam Monsen 2003-10-08 11:14:01 EDT
Thank you!
Comment 3 Adam Monsen 2003-10-08 13:48:03 EDT
For documentation purposes, I wanted to add that the fix worked and how exactly
I got it to work, in case it's helpful to a future Red Hat user.

After doing everything at http://cyberelk.net/tim/hpoj.html, I had to configure
the printer using redhat-printer-config.

I set it to be a locally-connected printer using the HP->Officejet G85->'hpijs'
driver.
Comment 4 Jay Turner 2004-09-01 22:10:54 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-228.html

Note You need to log in before you can comment on or make changes to this bug.