Bug 10656 - lines are rendered in the wrong position (ATI Rage 128)
lines are rendered in the wrong position (ATI Rage 128)
Status: CLOSED DUPLICATE of bug 10917
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-08 05:57 EDT by micha
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-19 14:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description micha 2000-04-08 05:57:23 EDT
Frequently, text lines that should be rendered in an application window
appear outside of the window.  It looks as if the rendering is starting at
the left of the screen when it should be at the left of the window.
Sometimes lines are on the top of the screen.
Sometimes lines "disappear".
(scrolling in netscape, joe, mc,... starts that thing)
I am using:
RedHat 6.2
XFree86-3.3.6-20
XFree86-SVGA-3.3.6-20
an ATI All in Wonder 128 (Rage 128)
Kernel 2.2.14-smp (first that one that was shipped with redhat, meanwhile
my own one without Framebuffer stuff compiled in...)
It doesn4t matter if i change from KDE to Gnome.
It doesn4t matter if i change resolution (1600x1200) to lower resolution

I don4t know any more what i can try...
Comment 1 micha 2000-04-10 12:55:59 EDT
It does not matter if i change from kdm to xdm or gpm. I get the same behaviour
if i change the graphics card (one aiw 128 to another; so the hardware is not
faulty)
Comment 2 micha 2000-04-13 06:27:59 EDT
Problems were solved by installing the xrage.rpm package from suse
(ftp://ftp.suse.com/pub/SuSE-Linux/suse_update/X/XFCom/xrage/xrage.rpm)
and erasing

rpm -e XFree86-XF86Setup-3.3.6-20
rpm -e XFree86-SVGA-3.3.6-20
rpm -Uvh xrage.rpm
ln -s /usr/X11R6/bin/XFCom_Rage128 /usr/X11R6/bin/XF86_SVGA
Comment 3 micha 2000-04-19 14:34:59 EDT
*** This bug has been marked as a duplicate of 10917 ***
Comment 4 D. Hugh Redelmeier 2000-04-26 22:30:59 EDT
I too observe this problem.  I'm using RH6.1, but with the SVGA server
from RH6.2.  My video card is an ATI Xpert 128 with the Rage 128 chip.
Very bothersome.  I don't really consider installing a Suse package
to be a resolution!

PS: putting "ATI Rage 128" in the summary would make finding this report
easier.
Comment 5 micha 2000-04-30 20:17:59 EDT
done...
Comment 6 Rob Russell 2000-05-23 10:47:59 EDT
This is a known issue with XFree86-3.3.6.  There is a small source
patch available on their FTP site here:

ftp://ftp.xfree86.org/pub/XFree86/3.3.6/fixes/fix-01-r128

I hope RedHat puts up an updated RPM, since I've got an entire office full of
machines with this problem, and I don't see SuSE RPMs as an acceptable solution.
Comment 7 D. Hugh Redelmeier 2000-05-23 12:09:59 EDT
I don't think that fix-01-r128 will fix the problem.
I installed the source RPM XFree86-3.3.6-20.src.rpm from RH6.2
and found that it already includes fix-01-r128.  This is the same
name as the binary RPM which does not work for me.
I did not verify that the patch was installed properly in the SRPM,
but it is listed in the spec file.
This makes it mysterious that the SUSE package works (but screen blanking
doesn't work with the SUSE package dropped into my RH6.1 system).

Note You need to log in before you can comment on or make changes to this bug.