Bug 1065860 - Gnome Shell display problem after update.
Summary: Gnome Shell display problem after update.
Keywords:
Status: CLOSED DUPLICATE of bug 1076981
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 07:06 UTC by ermanojghimire
Modified: 2014-03-24 23:46 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-24 23:46:38 UTC
Type: Bug


Attachments (Terms of Use)
just look at that hediously ugly and big buttons and the boarder for indicators.. (1.31 MB, image/png)
2014-02-17 07:06 UTC, ermanojghimire
no flags Details
Messed-up Gnome Shell (667.01 KB, image/png)
2014-02-27 16:15 UTC, Martin Engbers
no flags Details
Messed-up Gnome Shell 2 (1.29 MB, image/png)
2014-02-27 16:16 UTC, Martin Engbers
no flags Details
Messed-up Gnome Shell 3 (1.34 MB, image/png)
2014-02-27 16:17 UTC, Martin Engbers
no flags Details
journalctl from effected system (298.71 KB, text/plain)
2014-03-01 07:44 UTC, collura
no flags Details

Description ermanojghimire 2014-02-17 07:06:39 UTC
Created attachment 863969 [details]
just look at that hediously ugly and big buttons and the boarder for indicators..

Description of problem:
After Updating fedora 20 Gnome version with su -c 'yum update -y', gnome-shell was updated to gnome-shell-3.10.3-6.fc20.x86_64 , and that update has hediously ugly display, dash is ruiend, 

Version-Release number of selected component (if applicable):
gnome-shell-3.10.3-6.fc20.x86_64

How reproducible:
update fedora 20 to latest.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gawain Lynch 2014-02-17 14:08:00 UTC
Same here, it is caused by the backported high DPI support patch.

Reverting to 3.10.4-4 resolves the issue.

Comment 2 ermanojghimire 2014-02-19 14:30:03 UTC
(In reply to Gawain Lynch from comment #1)
> Same here, it is caused by the backported high DPI support patch.
> 
> Reverting to 3.10.4-4 resolves the issue.

ya I did downgrade after reporting the bug.. by su -c 'yum downgrade gnome-shell'

Comment 3 Martin Engbers 2014-02-27 16:14:53 UTC
I have similar problems, starting with gnome-shell-3.10.3-8. Not sure if it is caused by HiDPI support. I have attached three screenshots. Is this the same bug, or should I file a new one?

Comment 4 Martin Engbers 2014-02-27 16:15:59 UTC
Created attachment 868621 [details]
Messed-up Gnome Shell

Comment 5 Martin Engbers 2014-02-27 16:16:47 UTC
Created attachment 868622 [details]
Messed-up Gnome Shell 2

Comment 6 Martin Engbers 2014-02-27 16:17:34 UTC
Created attachment 868623 [details]
Messed-up Gnome Shell 3

Comment 7 collura 2014-03-01 07:44:04 UTC
Created attachment 869281 [details]
journalctl from effected system

have scrunched together icons as well and gear in bottom left corner and exit menu not viewable as falls off right side of screen.

maybe related to the negative size errors like these?:

'gnome-session[1607]: (gnome-shell:1878): Clutter-WARNING **: ./clutter-actor.c:9814: Actor 'StIMText' tried to allocate a size of -27.00 x 21.00'

Comment 8 Jarno Purontakanen 2014-03-02 07:25:51 UTC
I'm having the exact same problems as Commenter #3. Interestingly enough running "gnome-shell --replace" fixes it temporarily for that session.

Comment 9 Ali Akcaagac 2014-03-09 10:10:08 UTC
Ah! I thought I am the only one. Same situation here. I re-installed half of the GNOME packages. It's not that I don't have a lot of spare time.

(gnome-shell:1424): Clutter-WARNING **: ./clutter-actor.c:9814: Actor 'StIMText' tried to allocate a size of -22,00 x 16,00

Comment 10 Martin Engbers 2014-03-13 16:52:35 UTC
The issue seems to be solved in Fedora 20 now. gnome-shell 3.10.4.1 works as expected for me.

Comment 11 Samuel Sieb 2014-03-14 20:26:55 UTC
Did you mean gnome-shell-3.10.4-1?  I just had it happen to me when the screen locked.  Restarting gnome-shell in various ways wouldn't fix it.  But logging out and back in did.

There are several duplicates of this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1075545
https://bugzilla.redhat.com/show_bug.cgi?id=1071334
https://bugzilla.redhat.com/show_bug.cgi?id=1075744

Comment 12 Martin Engbers 2014-03-14 21:37:40 UTC
Yes, I meant 3.10.4-1. I think I remember 3.10.4-1 not working for me, so I downgraded it. But since upgradeing it again some days ago, it's been working flawlessly. Maybe another package interacting with gnome-shell was responsible for the earlyer trouble? Or maybe I'm just lucky. Anyway, disregard my comment above if the problem persists for you.

Comment 13 Ali Akcaagac 2014-03-16 14:24:55 UTC
Well I am affected by this issue as well and some systems that I maintain here are showing these sympthoms as well. My sister already called me up because she can't turn off the computer anymore because the items in the menu are not reachable anymore.

So what should we do ?

And why don't we get some feedback by the maintainer of this package or the Fedora QT team ?

From my own experiences over the past few years by using Fedora is, that most of the GNOME related bugs and issues that I reported were left unanswered until EOL sents up the automatic messages.

This is inacceptable.

Comment 14 Oscar Suro 2014-03-16 18:59:26 UTC
I also have the same issue, appeared when updated fedora. I found that booting to previous kernel 3.13.5.202 instead of 3.13.6.200 fixes the issue.

That said, when using 3.13.6.200 at log in screen, gnome-shell icons and spacing is correct, but it just breaks after logging in.

Also running gnome-shell.3.10.4-1

Comment 15 Martin Engbers 2014-03-16 20:52:48 UTC
I cannot reproduce the problem anymore, but if you find that the problem manifests itself differently with different kernel versions, than it would appear to be a graphics driver issue. I'm using an nVidia GeForce 9800 GT (nv50) with the open source nouveau driver. Is everybody else here also using nvidia hardware, or does this bug happen to radeon and intel users too?

Comment 16 Ali Akcaagac 2014-03-16 21:28:46 UTC
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320]

Radeon APU here.

Downgrading mutter and gnome-shell removed the issues on all systems that I maintain. So it clearly is a mutter and gnome-shell issue.

Comment 17 Ali Akcaagac 2014-03-16 21:32:54 UTC
More Fedora maintainance than actually using it to get my work done. It's with all Fedora releases that I used to use. Fedora is nice indeed but NOT for people who have serious work to do. It's more a playground for people with too much spare time.

Comment 18 Martin Engbers 2014-03-17 06:18:46 UTC
After yesterday's set of updates, the problem is back for me (after being gone for 4 days). The only packages remotely connected to gnome-shell in that transaction was the update to Mesa 10.0. So yeah, I still think the underlying problem might be located lower in the graphics stack. The problem is certainly exposed by the recent HiDPI patches to gnome-shell, and downgrading to a version prior to that patch resolves the issue.

Comment 19 Oscar Suro 2014-03-17 07:24:33 UTC
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4530/4570/545v]

Radeon Mobility here.

I started seeing the issue after updating gnome-shell, checked the yum history and I had no changes in Mesa drivers.

Even updating Mesa packages does not fix the issue. Will try downgrading gnome-shell.

Comment 20 Oscar Suro 2014-03-17 07:34:15 UTC
Running without issues in any kernel using gnome-shell.3.10.2.1-2

Comment 21 Ali Akcaagac 2014-03-17 11:14:06 UTC
Fixing the Kernel because someone applied broken (backported) patches to mutter/gnome-shell sounds a bit ridiculous to me. None of the other desktops that I've tried has shown any issues no matter what kernel used.

We have 21 comments now and none of the quality team neither the modules maintainer has responded so far.

Comment 22 Martin Engbers 2014-03-17 12:04:52 UTC
One of the commenters in the duplicate bug report #1071334 has posted a possible workaround that might solve the issue:

(1) Go to System Settings > Region & Language
(2) Change the "Formats" setting to something else
(3) Apply the change (this will require you to logout)
(4) Log in again
(5) Go to System Settings > Region & Language
(6) Change the "Formats" setting back to whatever it was
(7) Apply the change (this will require you to logout again)

I have no idea what the locale settings have to do with HiDPI support (someone speculated that it might be a decimal seperator parsing error) and this workaround seems fairly ridiculous, to be honest. But I just tried it and lo and behold, gnome-shell-3.10.4-1 once again works without any problems for me. Even after several restarts, the problem hasn't reappeared. I'd love to know if this actually works for other people too.

Comment 23 Martin Engbers 2014-03-17 12:07:09 UTC
If you cannot access System Settings because the menu is messed up, open a terminal and run "gnome-shell -r" to temporary eliminate the problem. The menu should then be available and you can try the proposed procedure above.

Comment 24 Oscar Suro 2014-03-24 06:29:05 UTC
There is a new version of gnome-shell 3.10.4-2 which seems to resolve the issue.
 
I noted that there was an update for mutter which address some HiDPI issues, so you might need to update that package too.

I believe this bug is a duplicate/related with 1076981, it may be convenient to update its state to reflect that.

Comment 25 Nicola Soranzo 2014-03-24 23:46:38 UTC

*** This bug has been marked as a duplicate of bug 1076981 ***


Note You need to log in before you can comment on or make changes to this bug.