Bug 106643 - Installer crash when creating >5 partitions within an extended partition.
Installer crash when creating >5 partitions within an extended partition.
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: parted (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
IHV would like this fixed in U1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-08 21:16 EDT by Larry Troan
Modified: 2016-04-18 05:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 21:23:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2003-10-08 21:16:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020424

Description of problem:
Anaconda crash when creating >5 partitions within an extended partition. 



Version-Release number of selected component (if applicable):
parted-1.6.3-29

How reproducible:
Always

Steps to Reproduce:
STEPS TO REPRODUCE:
1) Begin an install of RH EL 3 beta 1
2) Created enough partitions to exceed the 5 partition within the extended
partition.  I created partitions /a through /i (/a through /c on the primary; /d
through /i on the extended).
3) When creating the last partition (by double clicking on the partition
itself), I selected the rest of the disk.  Doing this caused anaconda to crash
and generate a report.  The install could not continue.

Actual Results:  Installer crash

Expected Results:  Install

Additional info:
Work-around: Select "new" and create the last partition that way (instead of
double clicking on the partition).

Duplicate of Bug 101432 (restricted access)
Comment 1 Larry Troan 2003-10-08 21:19:03 EDT
THIS BUG CREATED TO SHARE KNOWLEDGE WITH PUBLIC (original bug was IHV specific)

This is the error message when the problem occurs:

"Could not allocate requested partitions.  Partitioning failed: Could not
allocate cylinder based partitions."
Comment 2 Larry Troan 2003-10-08 21:19:28 EDT
------- Additional Comments From msf@redhat.com  2003-08-05 11:34 -------
If you increase the starting cylinder of the last partition you create by one,
or if that doesnt work, reduce the last cylinder number by one, or change both
limits if necessary.

There is a problem with parted (the partitioning library) that will occasionally
come up where it reports regions of the disk are available which are not.
Comment 3 Larry Troan 2003-10-08 21:20:32 EDT
Reducing the last cylinder number by one corrects the problem...will this be fixed?
Comment 4 Larry Troan 2003-10-08 21:21:22 EDT
------- Additional Comments From msf@redhat.com  2003-08-15 11:29 -------
This is a parted issue (previously reported against parted).
Comment 5 Larry Troan 2003-10-08 21:23:59 EDT
This is not fixed in RHEL3 "gold". You need to use the work-around described
above. Will attempt for fix in errata.

Note You need to log in before you can comment on or make changes to this bug.