Bug 106658 - autonegotioantion of network speed not always working working correctly
autonegotioantion of network speed not always working working correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 03:08 EDT by og
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 11:14:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description og 2003-10-09 03:08:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
not all network cards will choose the correct speed/duplex combination when
using dhcp for initial boot when ks.cfg later assigns a fixed address.

this might slow down the installation in an environment where 100baseTx-FD is
possible but only 10baseTx-HD is used.

it would be nice if mii-tool could be included into the ramdisk that gets loaded
via the network, since then one could adjust the network speed in the %pre
section and thus reduce installation time.

Version-Release number of selected component (if applicable):
all

How reproducible:
Always

Steps to Reproduce:
1. boot via vanilla dhcp into kickstart installation
2.
3.
    

Additional info:
Comment 1 Jeremy Katz 2003-10-09 11:14:58 EDT
Functionality is already present :-)

Add '--ethtool="speed 100 duplex full"' to the network line of your ks.cfg or
add 'ethtool="speed 100 duplex full"' to your command line on boot and it will
get set.

Note You need to log in before you can comment on or make changes to this bug.